标题:全球变暖
你有一张某海域NxN像素的照片,"."表示海洋、"#"表示陆地,如下所示:
.......
.##....
.##....
....##.
..####.
...###.
.......
其中"上下左右"四个方向上连在一起的一片陆地组成一座岛屿。例如上图就有2座岛屿。
由于全球变暖导致了海面上升,科学家预测未来几十年,岛屿边缘一个像素的范围会被海水淹没。具体来说如果一块陆地像素与海洋相邻(上下左右四个相邻像素中有海洋),它就会被淹没。
例如上图中的海域未来会变成如下样子:
.......
.......
.......
.......
....#..
.......
.......
请你计算:依照科学家的预测,照片中有多少岛屿会被完全淹没。
【输入格式】
第一行包含一个整数N。 (1 <= N <= 1000)
以下N行N列代表一张海域照片。
照片保证第1行、第1列、第N行、第N列的像素都是海洋。
【输出格式】
一个整数表示答案。
【输入样例】
7
.......
.##....
.##....
....##.
..####.
...###.
.......
【输出样例】
1
资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms
请严格按要求输出,不要画蛇添足地打印类似:“请您输入...” 的多余内容。
所有代码放在同一个源文件中,调试通过后,拷贝提交该源码。
不要使用package语句。不要使用jdk1.7及以上版本的特性。
主类的名字必须是:Main,否则按无效代码处理。
————————————————
#include <stdio.h>
#include <queue>
using namespace std;
char mp[1005][1005];
bool visited[1005][1005];
int n;
int xx[4] = {1, 0, -1, 0};
int yy[4] = {0, 1, 0, -1};
struct Node {
int x, y;
};
bool checkNodeYanmo(Node node) {
for (int i = 0; i < 4; i++) {
int next_x = node.x + xx[i];
int next_y = node.y + yy[i];
// 判断地图边界,这里注意下,如果有一面是水,那么一定会被淹没
if (next_x >= 0 && next_x < n && next_y >= 0 && next_y < n && mp[next_x][next_y] == '.') {
return true;
}
}
return false;
}
bool bfs(int x, int y) {
bool yanmo = true;
queue<Node> q;
q.push(Node{x, y});
visited[x][y] = true;
while (!q.empty()) {
Node tmp = q.front();
q.pop();
if (!checkNodeYanmo(tmp)) {
yanmo = false;
}
for (int i = 0; i < 4; i++) {
int next_x = tmp.x + xx[i];
int next_y = tmp.y + yy[i];
// 判断地图边界
if (next_x >= 0 && next_x < n && next_y >= 0 && next_y < n) {
if (mp[next_x][next_y] == '#' && visited[next_x][next_y] == false) {
q.push({next_x, next_y});
visited[next_x][next_y] = true;
}
}
}
}
return yanmo;
}
int solve() {
int ans = 0;
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
if (mp[i][j] == '#' && visited[i][j] == false) {
ans += bfs(i, j);
}
}
}
return ans;
}
int main() {
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%s", mp[i]);
}
printf("%d\n", solve());
return 0;
}