HihoCoder - 1631 —Cats and Fish(模拟)

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input

2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1

Sample Output

1 0
0 1
0 3

题意:

已知m条鱼,n只猫,每只猫吃一条鱼的时间,求经过x时间后,还有多少只完整的鱼,多少只不完整的鱼。(吃鱼时,效率高的猫优先)

思路:

模拟,详见代码

#include<bits/stdc++.h>
using namespace std;
int a[105];
bool judge[105];//judege[i]表示第i只猫是否正在吃鱼(用于求incomplete fish)
int main()
{
    int m,x,n;
    while(~scanf("%d%d%d",&m,&n,&x))
    {
        for(int i=0; i<n; ++i)
            scanf("%d",&a[i]);
        if(x==0)                       //特判x=0的情况
        {
            printf("%d 0\n",m);
            continue;
        }
        memset(judge,0,sizeof(judge));
        sort(a,a+n);                  //吃鱼时间从小到大排序(题意)
        for(int i=0; i<n; ++i)
        {
            if(m>0)
            {
                judge[i]=1;//一开始的时候有几个猫在吃鱼
                m--;        //剩下的完整的鱼数
            }
        }
        for(int i=1; i<=x; ++i)     //时间前进
        {
            for(int j=0; j<n; ++j)  //枚举猫
            {
                if(i%a[j]==0&&m>0&&i!=x)//刚够吃完一只鱼 且还有鱼剩下 且还有时间,那么吃下一条
                {
                    m--;
                }
                else if(i%a[j]==0) //刚好吃完,改变该猫的状态(不吃)
                judge[j]=0;
            }
        }
        int ans=0;
        for(int i=0; i<n; ++i)
        {
            if(judge[i]) ans++;
        }
        printf("%d %d\n",m,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值