01背包,我可不想被抓啊

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output
2
4
6

题意:
题意:求在不被抓的概率下所能偷得最大价值(01背包)

思路:
按照以往的思路:dp[i]中的i为容量大小(不被抓的概率),dp[i]存的是价值(金钱),{不被抓的概率在减小(容量慢慢减小),钱慢慢增多}
但这里概率是浮点数,无法作为数组的下标,曾想着将其划为整数,但是小数位数不一定是2位.

所以,只能换种思路来实现01背包.
dp[i]中的i为容量大小(金钱),dp[i]存的是价值(不被抓的概率){金钱慢慢减小,不被抓的概率慢慢减小(因为相乘的缘故)}

最后,在不被抓的概率下输出能得到的最大价值(利用一层for循环即可)

解析一组数据:
0.04 3 被抓的概率0.04 3家银行
1 0.02 第一家:抢1万元被抓的概率0.02
2 0.03 第二家:抢2万元被抓的概率0.03
3 0.05 第三家:抢3万元被抓的概率0.05

1.2.3家都抢,不被抓的概率=(1-0.02)(1-0.03)(1-0.05)=0.90307
1.家被抢,不被抓的概率=0.98

注意:每个事件相互独立,被抓的概率不能相加,也不能相乘,只能1-不被抓的概率,不被抓的概率是可以相乘的

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[10005];
double dp[10005];//dp[i]表示获得金钱i,不被抓的概率为dp[i];
double b[10005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double p;
        int n,i,j,sum=0;
        scanf("%lf %d",&p,&n);
        for(i=0;i<n;i++)
        {
            scanf("%d %lf",&a[i],&b[i]);
            sum+=a[i];
        }
        memset(dp,0,sizeof(dp));//
        dp[0]=1.0;//利用dp[0]可以给dp[1]赋值,利用已有的dp[]值可以给未被赋值dp赋值,最后所有的dp[]便都赋了值 
        for(i=0;i<n;i++)
        {
            for(j=sum;j>=a[i];j--)
            {
                dp[j]=max(dp[j],dp[j-a[i]]*(1-b[i]));
            }
        }
        for(i=sum;i>=0;i--)
        {//         >=也行
            if(dp[i]>(1-p))//不被抓的概率必须大于要求的不被抓概率
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值