蓝桥杯 ADV-171 算法提高 身份证号码升级

问题描述
  从1999年10月1日开始,公民身份证号码由15位数字增至18位。(18位身份证号码简介)。升级方法为:
  1、把15位身份证号码中的年份由2位(7,8位)改为四位。
  2、最后添加一位验证码。验证码的计算方案:
  将前 17 位分别乘以对应系数 (7 9 10 5 8 4 2 1 6 3 7 9 10 5 8 4 2) 并相加,然后除以 11 取余数,0-10 分别对应 1 0 x 9 8 7 6 5 4 3 2。
  请编写一个程序,用户输入15位身份证号码,程序生成18位身份证号码。假设所有要升级的身份证的四位年份都是19××年
输入格式
  一个15位的数字串,作为身份证号码
输出格式
  一个18位的字符串,作为升级后的身份证号码
样例输入
110105491231002
样例输出
11010519491231002x
数据规模和约定

  不用判断输入的15位字符串是否合理

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		BigInteger y = new BigInteger("10");
		BigInteger z = new BigInteger("1");
		BigInteger w = new BigInteger("9");
		BigInteger v = new BigInteger("11");
		BigInteger x = in.nextBigInteger();
		BigInteger[] a = new BigInteger[15];
		BigInteger[] b = new BigInteger[18];
		String[] c = { "1", "0", "x", "9", "8", "7", "6", "5", "4", "3", "2" };
		int[] q = { 7, 9, 10, 5, 8, 4, 2, 1, 6, 3, 7, 9, 10, 5, 8, 4, 2 };
		BigInteger sum = new BigInteger("0");
		String s = "0";
		String s2 = "17";
		BigInteger t = new BigInteger(s2);
		BigInteger mu = new BigInteger("1");
		for (int i = 14; i >= 0; i--) {
			a[i] = x.mod(y);
			x = x.divide(y);
		}
		for (int i = 0; i < 6; i++) {
			b[i] = a[i];
		}
		b[6] = z;
		b[7] = w;
		for (int i = 6; i < 15; i++) {
			b[i + 2] = a[i];
		}
		for (BigInteger e = new BigInteger(s); e.compareTo(t) < 0; e = e.add(new BigInteger("1"))) {
			int o = e.intValue();
			BigInteger g = new BigInteger("" + q[o]);
			mu = b[o].multiply(g);
			sum = sum.add(mu);
		}
		sum = sum.mod(v);
		for (int i = 0; i < 17; i++) {
			if (i == 16) {
				int j = sum.intValue();
				System.out.print(b[i] + c[j]);
				continue;
			}
			System.out.print(b[i]);
		}
		in.close();
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值