UVA - 572 Oil Deposits(DFS和BFS两种解法)

  Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *', representing the absence of oil, or ` @', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2


题意:

给你一个二维数组,要你算出油田有几块。

其中'@'是有油,'*'是没有油


解析:

这是一道基础的搜索题目

以下有两种解法:


dfs解法:如果遇到'@'就cut++,并把'@'周围的'@'都变为'*'

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int N = 110;
char map[N][N];
int m,n;
void dfs(int x,int y) {	
	if(x >= 0 && x <m && y >= 0 && y < n) {
		if(map[x][y] == '@') {
			map[x][y] = '*';
			for(int dr = -1; dr <= 1; dr++) {
				for(int dc = -1; dc <= 1; dc++) {
					if(!dr && !dc)
						continue;
					dfs(x+dr,y+dc);
				}
			}
		}
	}
}
int main() {
	int cut;
	while(cin >> m >> n && (m || n)) {
		getchar();
		for(int i = 0; i < m; i++) {
			for(int j = 0; j < n; j++) {
				cin >> map[i][j];
			}
		}
		cut = 0;
		for(int i = 0; i < m; i++) {
			for(int j = 0; j < n; j++) {
				if(map[i][j] == '@') {
					cut++;
					dfs(i,j);
				}
			}
		}
		cout<<cut<<endl;
	}
	return 0;
}

bfs解法:使用floodfill算法

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;

const int N = 110;
char grid[N][N];
int vis[N][N];
int h,w;

void bfs(int r ,int c) {	
	queue<int> q;	
	q.push(r);
	q.push(c);	
	while( !q.empty() ) {
		r = q.front();
		q.pop();
		c = q.front();
		q.pop();	
		for(int dr = -1; dr <= 1; dr++) {
			for(int dc = -1; dc <= 1; dc++) {
				if(!dr && !dc) { //dr和dc不能同时为0
					continue;
				}
				if(r + dr < 0 || r + dr >= h || c + dc < 0 || c + dc >= w) { //越界
					continue;
				}
				if( grid[r+dr][c+dc] == '@' && !vis[r+dr][c+dc]) {
					vis[r+dr][c+dc] = 1;
					q.push(r+dr);
					q.push(c+dc);
				}
			}
		}
	}
}

int main() {
	int cnt;
	while(scanf("%d%d",&h,&w) != EOF && ( h || w)) {
		memset(grid,0,sizeof(grid));
		memset(vis,0,sizeof(vis));
		for(int i = 0; i < h; i++) {
			scanf("%s",grid[i]);
		}
		int r,c;
		cnt = 0;
		for(int i = 0; i < h; i++) {
			for(int j = 0; j < w; j++) {
				if(grid[i][j] == '@' && !vis[i][j]) {	
					cnt++;
					bfs(i,j);
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,针对第二个问题的线程同步问题,我们可以使用同步方法和ReentrantLock可重入锁两种方式来解决。 ### 1. 同步方法 使用同步方法可以保证在同一时刻只有一个线程能够访问被synchronized关键字修饰的方法。在本例中,我们可以将withdraw和deposit方法都声明为同步方法,如下所示: ```java public synchronized void withdraw(double amount){ if (balance >= amount) { balance -= amount; System.out.println(Thread.currentThread().getName() + " withdraws " + amount + ", balance is " + balance); } else { System.out.println(Thread.currentThread().getName() + " withdraws failed, balance is " + balance); } } public synchronized void deposit(double amount){ if (amount > 0) { balance += amount; System.out.println(Thread.currentThread().getName() + " deposits " + amount + ", balance is " + balance); } else { System.out.println(Thread.currentThread().getName() + " deposits failed, balance is " + balance); } } ``` ### 2. ReentrantLock可重入锁 ReentrantLock可重入锁是一种更加灵活的线程同步方式,它比synchronized关键字提供了更多的功能,如公平锁、可中断锁、多条件变量等。在本例中,我们可以使用ReentrantLock来保证在同一时刻只有一个线程能够访问被锁住的代码块。具体实现如下: ```java private final ReentrantLock lock = new ReentrantLock(); public void withdraw(double amount){ lock.lock(); try { if (balance >= amount) { balance -= amount; System.out.println(Thread.currentThread().getName() + " withdraws " + amount + ", balance is " + balance); } else { System.out.println(Thread.currentThread().getName() + " withdraws failed, balance is " + balance); } } finally { lock.unlock(); } } public void deposit(double amount){ lock.lock(); try { if (amount > 0) { balance += amount; System.out.println(Thread.currentThread().getName() + " deposits " + amount + ", balance is " + balance); } else { System.out.println(Thread.currentThread().getName() + " deposits failed, balance is " + balance); } } finally { lock.unlock(); } } ``` 在以上代码中,我们使用了ReentrantLock的lock()和unlock()方法来手动加锁和解锁代码块。使用try-finally语句块的方式可以确保即使在代码块执行过程中出现异常,锁也能够被正确释放。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值