UVA - 208 Firetruck(回溯)


 Firetruck 

The Center City fire department collaborates with the transportation department to maintain maps of the city which reflects the current status of the city streets. On any given day, several streets are closed for repairs or construction. Firefighters need to be able to select routes from the firestations to fires that do not use closed streets.

Central City is divided into non-overlapping fire districts, each containing a single firestation. When a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and gives a list of possible routes from the firestation to the fire. You must write a program that the central dispatcher can use to generate routes from the district firestations to the fires.

Input

The city has a separate map for each fire district. Streetcorners of each map are identified by positive integers less than 21, with the firestation always on corner #1. The input file contains several test cases representing different fires in different districts.

  • The first line of a test case consists of a single integer which is the number of the streetcorner closest to the fire.
  • The next several lines consist of pairs of positive integers separated by blanks which are the adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and 7 on that section of the street.)
  • The final line of each test case consists of a pair of 0's.

Output

For each test case, your output must identify the case by number (CASE #1CASE #2, etc). It must list each route on a separate line, with the streetcorners written in the order in which they appear on the route. And it must give the total number routes from firestation to the fire. Include only routes which do not pass through any streetcorner more than once. (For obvious reasons, the fire department doesn't want its trucks driving around in circles.)

Output from separate cases must appear on separate lines.

The following sample input and corresponding correct output represents two test cases.

Sample Input

6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0

Sample Output

CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4
1 8 7 5 2 3 4
1 8 9 6 4
There are 8 routes from the firestation to streetcorner 4.


题目大意:输入一个n(n<=20)个节点的无向图以及某个节点k,按照字典序从小到大的顺序输出从节点1到节点k的所有路径,要求节点不能重复。

解析:从节点1往节点n查找可能会超时,所以我的想法是从节点n往节点1查找,然后用一个字符串逆序保存,但是数组保存完是逆序的字典序列,再将字符串排序,就能按照字典序输出了。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int N = 22;
const int MAX = 1000;
int edge[N][N];
bool vis[N];
int road[N];
int n;
int cnt,p;
char str[MAX][N];

int cmp(const void *a,const void *b) {
	return strcmp((char *)a,(char *)b);
}

void dfs(int u,int p) {
	if(u == 1) {
		for(int i = p -1,j = 0; i >= 0; i-- , j++) {
			str[cnt][j] = road[i] + '0';
		}
		str[cnt][p] = '\0';
		cnt++;
		return ;
	}
	for(int i = 1; i <= N; i++) {
		if(edge[u][i] && !vis[i]) {
			vis[i] = true;
			road[p] = i;
			dfs(i,p+1);
			vis[i] = false;
		}
	}
}
int main() {
	int u,v;
	int cas = 1;
	while( scanf("%d",&n) != EOF) {
		memset(edge,0,sizeof(edge));
		memset(vis,0,sizeof(vis));
		while(1) {
			scanf("%d%d",&u,&v);
			if( !u && !v) {
				break;
			}
			edge[u][v] = edge[v][u] = 1;
		}
		printf("CASE %d:\n",cas++);
		cnt = 0;
		p = 1;
		road[0] = n;
		vis[n] = true;
		dfs(n,1);
		qsort(str,cnt,sizeof(str[0]),cmp);
		for(int i = 0; i < cnt; i++) {
			int len =  strlen(str[i]);
			for(int j = 0;j < len-1; j++) {
				printf("%d ",str[i][j] - '0');
			}
			printf("%d\n",str[i][len-1] - '0');
		}
		printf("There are %d routes from the firestation to streetcorner %d.\n",cnt,n);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值