UVA - 270 Lining Up(贪心)

 Lining Up 

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3


题目大意:想在给你t组样例,每组用一个空行隔开,每组样例中的每个数代表的是每个点的(x,y),问:你能否找出,最多位于一条直线上的点。

解析:可以先枚举每个点和其他点间的斜率,并将这些斜率存入数组中,并将该数组进行排序,算出最多的斜率数,最多斜率数+1,就是最多位于一条直线上点的个数。

注意:每个样例之间要输出一个空行。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 10000;
struct P{
	int x,y;
}p[N];
char str[N];
int main() {
	int t;
	double k[N];
	scanf("%d",&t);
	getchar();getchar();
	while(t--) {
		int cnt = 0;
		while(gets(str)) {
			if(str[0] == '\0') {
				break;
			}
			sscanf(str,"%d%d",&p[cnt].x,&p[cnt].y);
			cnt++;
		}
		int sum,max = -1;
		for(int i = 0; i < cnt; i++) {
			int num = 0;
			for(int j = 0; j < cnt; j++) {
				if(i == j) {
					continue;
				}
				if(p[i].x != p[j].x) {
					k[num++] = (double)(p[i].y - p[j].y) / (double)(p[i].x - p[j].x);
				}else {
					k[num++] = 1e-8;
				}
			}
			sort(k,k+num);
			sum = 2;
			for(int j = 0; j < num-1; j++) {
				if(k[j] == k[j+1]) {
					sum++;
				}else {
					sum = 2;
				}
				if(sum > max) {
					max = sum;
				}
			}
		}
		printf("%d\n",max);
		if(t) {
			printf("\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值