Encoding

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 100.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output

ABC
A2B3C

Source

ZHANG, Zheng
#include <stdio.h>
#include<string.h>
#include <stdlib.h>


int main()
{
    int t,len,i,count;
        char ch[110];
    while(~scanf("%d",&t))
    {
        while(t--)
        {
                        scanf("%s",ch);
            len=strlen(ch);
                        i=0;
            while(i<len)
            {
                                count=1;
                i+=1;

                if(ch[i-1]==ch[i]&&i<len)
                {
                                        while(ch[i-1]==ch[i])
                    {
                                                i++;
                                                count++;
                                        }
                    printf("%d",count);
                    printf("%c",ch[i-1]);
                }
                else
                    printf("%c",ch[i-1]);
                }
                puts("");
                }
      }
      return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值