2017 Multi-University Training Contest - Team 1 Function

Function

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1289    Accepted Submission(s): 591


Problem Description
You are given a permutation a from 0 to n1 and a permutation b from 0 to m1 .

Define that the domain of function f is the set of integers from 0 to n1 , and the range of it is the set of integers from 0 to m1 .

Please calculate the quantity of different functions f satisfying that f(i)=bf(ai) for each i from 0 to n1 .

Two functions are different if and only if there exists at least one integer from 0 to n1 mapped into different integers in these two functions.

The answer may be too large, so please output it in modulo 109+7 .
 

Input
The input contains multiple test cases.

For each case:

The first line contains two numbers n, m . (1n100000,1m100000)

The second line contains n numbers, ranged from 0 to n1 , the i -th number of which represents ai1 .

The third line contains m numbers, ranged from 0 to m1 , the i -th number of which represents bi1 .

It is guaranteed that n106, m106 .
 

Output
For each test case, output " Case # x : y " in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

Sample Input
  
  
3 2 1 0 2 0 1 3 4 2 0 1 0 2 3 1
 

Sample Output
  
  
Case #1: 4 Case #2: 4

a[]的排列确定出f[i]的递推关系,构成几个递推环,b[]的排列构成答案环,如果b[]中的环长度能作为a[]环的因子,那么b[]环作为结果代入,就没有矛盾

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const long long MOD= 1e9+7;
int n,m;
int a[111111],b[111111];
int f[111111];
vector<int>Va,Vb;
int ncase=0;
int main()
{
    while(scanf("%d%d",&n,&m)==2)
    {
        Va.clear();Vb.clear();
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        for(int i=0;i<m;i++)scanf("%d",&b[i]);
        memset(f,-1,sizeof(f));
        for(int i=0;i<n;i++)
        {
            if(f[a[i]]==-1)
            {
                //f[a[i]]=0;
                int cnt=0;
                int k=a[i];
                while(f[a[k]]==-1)
                {
                    f[a[k]]=0;
                    k=a[k];
                    cnt++;
                }
                if(cnt){Va.push_back(cnt);}
            }
        }
        //for(int i=0;i<Va.size();i++)cout<<Va[i]<<" ";
        memset(f,-1,sizeof(f));
        for(int i=0;i<m;i++)
        {
            if(f[b[i]]==-1)
            {
                //f[a[i]]=0;
                int cnt=0;
                int k=b[i];
                while(f[b[k]]==-1)
                {
                    f[b[k]]=0;
                    k=b[k];
                    cnt++;
                }
                if(cnt){Vb.push_back(cnt);}
            }
        }
        sort(Va.begin(),Va.end());
        sort(Vb.begin(),Vb.end());
        int lena=Va.size();
        int lenb=Vb.size();
        long long ans=1;
        int  flag=0;
        for(int i=0;i<lena;i++)
        {
            long long mul=0;
            for(int j=0;j<lenb;j++)
            {
                if(Va[i]<Vb[j])break;
                if(Va[i]%Vb[j]==0){mul+=Vb[j];}
            }
            if(mul){flag++;ans=ans*mul%MOD;}
            else {ans=0;break;}
        }
        //if(flag<lena)ans=0;
        printf("Case #%d: %lld\n",++ncase,ans);
    }
    return 0;
}








  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值