建立虚拟子网,实现全网可达

 一、交换机配置vlan

交换机1

[Huawei]interface     
[Huawei]interface e0/0/2   
[Huawei-Ethernet0/0/2]port link-type access 
[Huawei-Ethernet0/0/2]port default vlan 2
[Huawei]interface e0/0/3  
[Huawei-Ethernet0/0/3]port link-type access
[Huawei-Ethernet0/0/3]port default vlan 3
[Huawei]interface e0/0/4  
[Huawei-Ethernet0/0/4]port link-type access 
[Huawei-Ethernet0/0/4]port default vlan 4
[Huawei]interface e0/0/5
[Huawei-Ethernet0/0/5]port link-type access
[Huawei-Ethernet0/0/5]port default vlan 5
[Huawei]interface  e0/0/1  
[Huawei-Ethernet0/0/1]port link-type trunk     
[Huawei-Ethernet0/0/1]port trunk allow-pass vlan all

交换机2

[Huawei]interface e0/0/2
[Huawei-Ethernet0/0/2]port link-t access 

[Huawei-Ethernet0/0/2]port default vlan 2
[Huawei]interface e0/0/3
[Huawei-Ethernet0/0/3]port link-type access 
[Huawei-Ethernet0/0/3]port default vlan 3
[Huawei]interface e0/0/1
[Huawei-Ethernet0/0/1]port link-type trunk     
[Huawei-Ethernet0/0/1]port trunk allow-pass vlan all 

二、配置路由器虚拟子接口

开启DHCP服务

[r1]dhcp enable

配置虚拟子接口
r1 路由器

[r1]interface g0/0/0.1
[r1-GigabitEthernet0/0/0.1]dot1q termination vid 2
[r1-GigabitEthernet0/0/0.1]quit
[r1]interface g0/0/0.2
[r1-GigabitEthernet0/0/0.2]dot1q termination vid 3
[r1-GigabitEthernet0/0/0.2]quit
[r1]interface g0/0/0.3
[r1-GigabitEthernet0/0/0.3]dot1q termination vid 4
[r1-GigabitEthernet0/0/0.3]quit
[r1]interface g0/0/0.4
[r1-GigabitEthernet0/0/0.4]dot1q termination vid 5
[r1-GigabitEthernet0/0/0.4]quit

r3路由器

[r3]interface g0/0/1.1
[r3-GigabitEthernet0/0/1.1]dot1q termination vid 2
[r3]interface g0/0/1.2
[r3-GigabitEthernet0/0/1.2]dot1q termination vid 3

配置虚拟子接口IP

r1

[r1]interface g0/0/0.1
[r1-GigabitEthernet0/0/0.1]ip address 172.16.1.1 24
[r1]interface g0/0/0.2
[r1-GigabitEthernet0/0/0.2]ip address 172.16.2.1 24
[r1]interface g0/0/0.3
[r1-GigabitEthernet0/0/0.3]ip address 172.16.3.1 24
[r1]interface g0/0/0.4
[r1-GigabitEthernet0/0/0.4]ip address 172.16.4.1 24

建立地址池,配置调用DHCP服务 

[r1]ip pool 1 
[r1-ip-pool-1]network 172.16.1.0 mask 24
[r1-ip-pool-1]gateway-list 172.16.1.1 
[r1-ip-pool-1]dns-list 8.8.8.8
[r1-ip-pool-1]quit 
[r1]ip pool 2 
[r1-ip-pool-2]network 172.16.2.0 mask 24    
[r1-ip-pool-2]gateway-list 172.16.2.1     
[r1-ip-pool-2]dns-list 8.8.8.8
[r1-ip-pool-2]quit 
[r1]ip pool 3
[r1-ip-pool-3]network 172.16.3.0 mask 24
[r1-ip-pool-3]gateway-list 172.16.3.1    
[r1-ip-pool-3]dns-list 8.8.8.8
[r1-ip-pool-3]quit
[r1]ip pool 4
[r1-ip-pool-4]network 172.16.4.0 mask 24
[r1-ip-pool-4]gateway-list 172.16.4.1    
[r1-ip-pool-4]dns-list 8.8.8.8  
[r1-ip-pool-4]quit 
[r1]interface g0/0/0.1
[r1-GigabitEthernet0/0/0.1]dhcp select global    
[r1-GigabitEthernet0/0/0.1]quit 
[r1]interface g0/0/0.2    
[r1-GigabitEthernet0/0/0.2]dhcp select global 
[r1-GigabitEthernet0/0/0.2]quit  
[r1]interface g0/0/0.3 
[r1-GigabitEthernet0/0/0.3]dhcp select global
[r1-GigabitEthernet0/0/0.3]quit 
[r1]interface g0/0/0.4
[r1-GigabitEthernet0/0/0.4]dhcp select global  
[r1-GigabitEthernet0/0/0.4]quit 
[r1]interface g0/0/0.1
[r1-GigabitEthernet0/0/0.1]arp broadcast enable     
[r1-GigabitEthernet0/0/0.1]quit     
[r1]interface g0/0/0.2 
[r1-GigabitEthernet0/0/0.2]arp broadcast enable   
[r1-GigabitEthernet0/0/0.2]quit 
[r1]interface g0/0/0.3
[r1-GigabitEthernet0/0/0.3]arp broadcast enable  
[r1-GigabitEthernet0/0/0.3]quit 
[r1]interface g0/0/0.4
[r1-GigabitEthernet0/0/0.4]arp broadcast enable 
[r1-GigabitEthernet0/0/0.4]quit 

r3

[r3]interface g0/0/1.1
[r3-GigabitEthernet0/0/1.1]ip address 192.168.1.1 24
[r3]interface g0/0/1.2
[r3-GigabitEthernet0/0/1.2]ip address 192.168.2.1 24
[r3]ip pool 1
[r3-ip-pool-1]network 192.168.1.0 mask 24    
[r3-ip-pool-1]gateway-list 192.168.1.1 
[r3-ip-pool-1]dns-list 8.8.8.8    
[r3-ip-pool-1]quit 
[r3]ip pool 2  
[r3-ip-pool-2]network 192.168.2.0 mask 24
[r3-ip-pool-2]gateway-list 192.168.2.1    
[r3-ip-pool-2]dns-list 8.8.8.8        
[r3-ip-pool-2]quit 
[r3]interface g0/0/1.1
[r3-GigabitEthernet0/0/1.1]dhcp select global 
[r3-GigabitEthernet0/0/1.1]arp broadcast enable .
[r3]interface  g0/0/1.2
[r3-GigabitEthernet0/0/1.2]dhcp select global 
[r3-GigabitEthernet0/0/1.2]arp broadcast enable 

启用ospf服务   

[r1]ospf 100 router-id 1.1.1.1
[r1-ospf-100]area 0    
[r1-ospf-100-area-0.0.0.0]network 0.0.0.0 255.255.255.255
[r2]ospf 100 router-id 2.2.2.2
[r2-ospf-100]area 0 
[r2-ospf-100-area-0.0.0.0]network 0.0.0.0 255.255.255.255
[r3]ospf 100 router-id 3.3.3.3
[r3-ospf-100]area 0
[r3-ospf-100-area-0.0.0.0]netw    
[r3-ospf-100-area-0.0.0.0]network 0.0.0.0 255.255.255.255


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值