在一个正方形的灰度图片上,肿瘤是一块矩形的区域,肿瘤的边缘所在的像素点在图片 中用 0 表示。其它肿瘤内和肿瘤外的点都用 255 表示。现在要求你编写一个程序,计算肿瘤内部的像素点

问题描述】

在一个正方形的灰度图片上,肿瘤是一块矩形的区域,肿瘤的边缘所在的像素点在图片 中用 0 表示。其它肿瘤内和肿瘤外的点都用 255 表示。现在要求你编写一个程序,计算肿瘤内部的像素点的个数(不包括肿瘤边缘上的点)。已知肿瘤的边缘平行于图像的边缘。

【输入形式】

输入的第一行是一个正整数n(3<=n<=600),表示正方形的边长,接下来的n行,每行有n个由空格隔开的n个整数,表示每个像素点。
【输出形式】

输出包括一行,这一行只包含一个整数,表示肿瘤内部的像素点的个数。

【样例输入】

3
0 0 0
0 255 0
0 0 0

【样例输出】

1

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int a[601][601];//定义一个数组 
	int x1=-1,y1=-1,x2=-1,y2=-1;//x1,y1,左上角的坐标  x2,y2 右下角的坐标 
	int n;
	cin>>n;
	for(int i=0;i<n;i++)//输入数据 
	{
		for(int j=0;j<n;j++)
		{
			cin>>a[i][j];
		}
	}
	for(int i=0;i<n;i++)//判断x1,y1的位置 
	{
		for(int j=0;j<n;j++)
		{
			if(a[i][j]==0)
			{
				x1=i;y1=j;
				break;			
			}
		}
				if(x1!=-1)
			break;	
	}
	for(int i=0;i<n;i++)//判断x2,y2的位置 
	{
		for(int j=0;j<n;j++)
		{
			if(a[i][j]==0)
			{
				x2=i;y2=j;			
			}
		}
	}
	int c,k;
	c=x2-x1-1;
	k=y2-y1-1;
	int sum;
	sum=c*k;
	cout<<sum;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
要求: 1、写出设计思路、算法思路。 2、写出程序。 3、运行结果截图。 第1题、两倍 给定2到15个不同的正整数,你的任务是计算这些数里面有多少个数对满足:数对中一个 数是另一个数的两倍。比如给定 1 4 3 2 9 7 18 22 得到的答案是3,因为2是1的两倍,4是2的两倍,18是9的两倍。 第2题、肿瘤面积 在一个正方形灰度图片上,肿瘤一块矩形区域肿瘤边缘所在的像素点图片 中用0表示,其他肿瘤内和肿瘤的点都用255表示编写一个程序计算肿瘤内部的像 素的点的个数(不包括肿瘤边缘上的点)。已知肿瘤边缘平行于图像的边缘。图像数 据中第一行为图像像素的行数和列数,随后为像素数据。比如,图像数据为 7 14 255 255 255 255 255 255 255 255 255 255 255 255 255 255 255 255 255 0 0 0 0 0 0 0 0 255 255 255 255 255 255 0 255 255 255 255 255 255 0 255 255 255 255 255 255 0 255 255 255 255 255 255 0 255 255 255 255 255 255 0 255 255 255 255 255 255 0 255 255 255 255 255 255 0 0 0 0 0 0 0 0 255 255 255 255 255 255 255 255 255 255 255 255 255 255 255 255 255 结果为18。 第3题、FBI树 二进制串只能由"0"和"1"组成。将由"0"和"1"组成的字符串分为三类:全"0"串称为B串 ,全"1"串称为I串,既含"0"又含"1"的串则称为F串。 二进制串可以转换为FBI树结构,FBI树是一棵二叉树,在该二叉树中包含F节点、B节点 和I节点三种。 可以将一个长度为2n的二进制串S构造为一棵FBI树T,方法为: T的根结点为R,其类型与串S的类型相同; 若串S的长度大于1,将串S从中间分开,分为等长的左右子串S1和S2;由左子串S1构造R 的左子树T1,由右子串S2构造R的右子树T2。 现在给定一个长度为2n的二进制串,请用上述构造方法构造出一棵FBI树,并输出它的后 序遍历序列。 输入数据有2行,第一行是一个整数N(0<=N<=10),第二行是一个长度为2N的二进制串。 如输入数据为 3 11011000 输出为 IIIBIFFIBFBBBFF 第4题(http://poj.org/problem?id=1050) To the Max Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 25250 Accepted: 13051 Description Given a two-dimensional array of positive and negative integers, a sub- rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. As an example, the maximal sub-rectangle of the array: 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 –2 is in the lower left corner: 9 2 -4 1 -1 8 and has a sum of 15. Input The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the ar

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值