数据结构实验之链表一:顺序建立链表
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。
Input
第一行输入整数的个数N;
第二行依次输入每个整数。
第二行依次输入每个整数。
Output
输出这组整数。
Example Input
8 12 56 4 6 55 15 33 62
Example Output
12 56 4 6 55 15 33 62
Hint
不得使用数组!
#include<stdio.h>
#include<stdlib.h>
typedef struct node{
int data;
struct node *next;
}*linkList;
void creatList(linkList &L,int n){
struct node *p, *tail;
L =new node;
tail = L;
for(int i = 0; i < n; i++){
p = (struct node*)malloc(sizeof(struct node));
scanf("%d", &p->data);
p->next = NULL;
tail->next = p;
tail = p;
}
};
void outputData(linkList &L){
struct node *p;
p = L->next;
while(p){
if(p->next == NULL)
printf("%d\n", p->data);
else
printf("%d ", p->data);
p = p->next;
}
}
int main(){
int n;
scanf("%d", &n);
linkList L;
creatList(L, n);
outputData(L);
return 0;
}