数据结构实验之栈与队列十:走迷宫
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
一个由n * m 个格子组成的迷宫,起点是(1, 1), 终点是(n, m),每次可以向上下左右四个方向任意走一步,并且有些格子是不能走动,求从起点到终点经过每个格子至多一次的走法数。
Input
第一行一个整数T 表示有T 组测试数据。(T <= 110)
对于每组测试数据:
第一行两个整数n, m,表示迷宫有n * m 个格子。(1 <= n, m <= 6, (n, m) !=(1, 1) ) 接下来n 行,每行m 个数。其中第i 行第j 个数是0 表示第i 行第j 个格子可以走,否则是1 表示这个格子不能走,输入保证起点和终点都是都是可以走的。
任意两组测试数据间用一个空行分开。
Output
对于每组测试数据,输出一个整数R,表示有R 种走法。
Example Input
3 2 2 0 1 0 0 2 2 0 1 1 0 2 3 0 0 0 0 0 0
Example Output
1 0 4
老师讲了用栈的方法做,但是没有写出来。
其实就是从起点处,挨个方向遍历,如果走不通,就换另一个方向,四个方向都已经走不通了就退回前一个格子,最终如果能走到目标就是可行的,否则没有一条通路。
#include<iostream>
#include<cstdio>
using namespace std;
int n, m;
int step = 0;
int book[1000][1000], e[1000][1000];
void dfs(int x, int y)
{
int next[4][2] = {{-1,0},{0,1},{1,0},{0,-1}};
int tx, ty;
if(x == n&&y == m)
{
step++;
return;
}
for(int i = 0;i<4;i++)
{
tx = x+next[i][0];
ty = y+next[i][1];
if(tx<1||tx>n||ty<1||ty>m) continue;
if(e[tx][ty] == 0&&book[tx][ty] == 0)
{
book[tx][ty] = 1;
dfs(tx, ty);
book[tx][ty] = 0;
}
}
return;
}
int main()
{
int t, i, j;
scanf("%d", &t);
while(t--)
{
step = 0;
scanf("%d%d", &n,&m);
for(i = 1;i<=n;i++)
{
for(j = 1;j<=m;j++)
{
scanf("%d", &e[i][j]);
}
}
book[1][1] = 1;
dfs(1, 1);
printf("%d\n", step);
}
}