数据结构实验之二叉树四:(先序中序)还原二叉树

数据结构实验之二叉树四:(先序中序)还原二叉树

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

 

Output

 输出一个整数,即该二叉树的高度。

Example Input
9 
ABDFGHIEC
FDHGIBEAC
Example Output
5
通过一颗二叉树的先序和中序遍历序列,就可以确定还原一颗二叉树。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef struct node{
	char data;
	struct node *lchild, *rchild;
}*bitTree;
int cnt = 0;
char str[100];
bitTree rebuild(char *a, char *b, int n){
    bitTree root;
    int i;
    if(n <= 0)
        return NULL;               //空树  
    root  =new node;
    root->data = *a;               //获得根节点的数据
    for(i = 0; i < n; i++){
        if(b[i] == a[0])           //确定子树的根节点 
            break;
    }
    root->lchild = rebuild(a+1, b, i);   //递归还原二叉树
    root->rchild = rebuild(a+1+i, b+i+1, n-i-1);
    return root;
}
 int depth(bitTree root)
{
   int d1, d2;
   if (root != NULL)
   {
   d1 = depth(root->lchild);
   d2 = depth(root->rchild);
   if (d1 > d2)
     return d1 + 1;
    else
    return d2 + 1;
    }
    return 0;
}

int main(){
    char xianxu[55], zhongxu[55];
    bitTree root;
    int n;
	while(~scanf("%d", &n)){
        scanf("%s", xianxu);
        scanf("%s", zhongxu);
		cnt = 0;
		//createTree(root, str);
		root = rebuild(xianxu, zhongxu, n);
		printf("%d\n", depth(root));
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值