NYOJ 58 最少步数

最少步数

时间限制:3000 ms  |  内存限制:65535 KB

难度: 4
            描述

这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1
 1,0,0,1,0,0,1,0,1
 1,0,0,1,1,0,0,0,1
 1,0,1,0,1,1,0,1,1
 1,0,0,0,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,0,0,0,1
 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入
第一行输入一个整数n(0<n<=100),表示有n组测试数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7
样例输出
12
11 

分析:

求一点到另一点的最小步数,广搜,用队列保存节点,遍历图,直到找到目标

代码如下:

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
struct Node
{
    int ix, iy;
    int iCount;
};
Node sbegin, send;
int iVis[9][9];
int iMin;
int iDir[][2] = {-1, 0, 0, -1, 1, 0, 0 ,1};
int iMap[9][9] =
{
    1,1,1,1,1,1,1,1,1,
    1,0,0,1,0,0,1,0,1,
    1,0,0,1,1,0,0,0,1,
    1,0,1,0,1,1,0,1,1,
    1,0,0,0,0,1,0,0,1,
    1,1,0,1,0,1,0,0,1,
    1,1,0,1,0,1,0,0,1,
    1,1,0,1,0,0,0,0,1,
    1,1,1,1,1,1,1,1,1
};
int check(Node s)  //检查s是否满足要求
{
    int x = s.ix, y = s.iy;
    if(x >= 0 && x <= 8 && y >= 0 && y <= 8 && iMap[x][y] == 0 && !iVis[x][y])
        return 1;
    return 0;
}
void bfs(Node st)
{
    queue<Node> q;
    Node now, next;
    st.iCount = 0;   //记录步数,先清0
    q.push(st);    //入队列
    iVis[st.ix][st.iy] = 1;   //标记
    while(!q.empty())
    {
        now = q.front();
        if(now.ix == send.ix && now.iy == send.iy)   //若查找到目标
        {
            iMin = now.iCount;
            return;
        }
        for(int i = 0; i < 4; i ++)  //未找到,搜索四周
        {
            next.ix = now.ix + iDir[i][0];
            next.iy = now.iy + iDir[i][1];
            next.iCount = now.iCount + 1;
            if(check(next))
            {
                q.push(next);
                iVis[next.ix][next.iy] = 1;
            }
        }
        q.pop();
    }
    return;
}
int main()
{
    int n;
    cin >>n;
    while(n--)
    {
        iMin = 999999999;
        memset(iVis, 0, sizeof(iVis));
        cin >>sbegin.ix >>sbegin.iy >>send.ix >>send.iy;
        bfs(sbegin);
        cout <<iMin <<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值