【转载】centos7中Scrapy :No module named Twisted.persisted的解决方案与原因解析

原文出处:https://blog.csdn.net/ZunHaiFuXi/article/details/79943904

 

安装scripy时,所有步骤、依赖都装好了, 使用python3.6 引入scrapy时候报错 


这是因为pip insatall twisted 安装的版本低 不能支持python3.6 

去twisted官网

由于使用python3.6,因此需要下载最新的17.9.0版本,此版本已经支持python3.6

1.下载对应python3.6的版本 这里直接给个链接

wget https://twistedmatrix.com/Releases/Twisted/17.9/Twisted-17.9.0.tar.bz2

2.解压下载下来的Twisted-17.9.0.tar.bz2
tar -xvf Twisted-17.9.0.tar.bz2
3.安装
进入解压后的目录,执行:
python setup.py install

安装完成之后,便可以正常使用Scrapy了,小伙伴们,快去试试吧!


大功告成 希望对大家有所帮助

阅读更多
换一批

没有更多推荐了,返回首页