hdu2141

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 


题目意思,在A、B、C三个数组中找是否存在和为X的一组数,有则输出yes没有输出no


如果直接暴力写O(S*N^3)肯定超时了,因此选择用暴力+二分的方法

先将A、B数组的和存入数组AB,然后在数组AB中二分查找

#include<iostream>
#include<stdlib.h>
#include<string>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
int a[501];
int b[501];
int c[501];
int ab[500*500];
int x;
bool bs(int f){
    int l=0,r=x-1;
    while(l<=r){
        int mid=(l+r)>>1;
        if(f<ab[mid])r=mid-1;
        else if(f>ab[mid])l=mid+1;
        else return true;
    }
    return false;
}

int main(){
#ifdef LOCAL
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
#endif
    int Case=0;
    int n,m,k;
    while(scanf("%d",&n)!=EOF){
        Case++;
        printf("Case %d:\n",Case);
        scanf("%d%d",&m,&k);
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        for(int i=0;i<m;i++)scanf("%d",&b[i]);
        for(int i=0;i<k;i++)scanf("%d",&c[i]);
        x=0;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                ab[x++]=a[i]+b[j];
            }
        }
        int s=0;
        scanf("%d",&s);
        sort(ab,ab+x);
        sort(c,c+k);
        for(int i=0;i<s;i++){
            int que=0;
            int temp=0;
            scanf("%d",&que);
            for(int i=0;i<k;i++){
                if(bs(que-c[i])){
                    temp=1;
                    printf("YES\n");
                    break;
                }
            }
            if(!temp)printf("NO\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值