HDU-1059 母函数

Dividing
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27421 Accepted Submission(s): 7875

Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output

For each colletcion, output Collection #k:'', where k is the number of the test case, and then eitherCan be divided.” or “Can’t be divided.”.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can’t be divided.

Collection #2:
Can be divided.


看了别人的思路


这题如果直接用母函数的话,数据规模会太大,导致超时。所以要对原始数据先进行处理一下。如果一种marble的个数为偶数,那么这种marble就可以均分。所以每中marble都对一个偶数取模。再对处理过后的数据计算。如果求得这是marble的总价值为奇数,则不可能均分。如果为偶数,则进行母函数的运算。如果sum/2的项不为0则说明可以均分。

代码:

#include<iostream>
using namespace std;
int main()
{
    int num[6],test=1;;
    for(int i=0;i<6;i++) cin>>num[i];
    while(num[0]!=0||num[1]!=0||num[2]!=0||num[3]!=0||num[4]!=0||num[4]!=0)
    {
        int sum=0;
        for(int i=0;i<6;i++)
        {
            num[i]=num[i]%60;
            sum+=num[i]*(i+1);
        }
        if(sum%2!=0)
        {
            cout<<"Collection #"<<test<<":"<<endl;
            cout<<"Can't be divided." <<endl;
            test++;
        }
        else
        {
            int ans[1000];
            int b[1000];
            for(int i=0;i<1000;i++)
            {
                ans[i]=0;
                b[i]=0;
            }
            for(int i=0;i<=num[0];i++) ans[i]=1;
            for(int i=1;i<6;i++)
            {
                for(int j=0;j<1000;j++)
                {
                    for(int k=0;k+j<1000&&k<=num[i]*(i+1);k+=i+1)
                    {
                        b[j+k]+=ans[j];
                    }
                }
                for(int i=0;i<1000;i++)
                {
                    ans[i]=b[i];
                    b[i]=0;
                }
            }
            if(ans[sum/2]==0)
            {
                cout<<"Collection #"<<test<<":"<<endl;
                cout<<"Can't be divided." <<endl;
                test++;
            }
            else
            {
                cout<<"Collection #"<<test<<":"<<endl;
                cout<<"Can be divided."<<endl;
                test++;
            }
        }
        cout<<endl;
        for(int i=0;i<6;i++) cin>>num[i];
    }
}

有一个很重要的点,就是这个偶数怎么取。参考别人的例子大部分是取了60.一开始我用2取模,结果是wrong answer。又试了其他偶数,发现6,8,10.。。。之后的偶数都可以。2,4不可以。这个偶数应该不可以太小。例如2的话,相当于每一种marble都均分。但这种分法是很不合理的。。。。所以这个数要取的相对大一些。但是具体怎么取,并不知道。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值