HDU - 2822 Dogs(广搜+优先队列)

Dogs

                                                                                 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                          Total Submission(s): 2996    Accepted Submission(s): 1135


Problem Description
Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim's), So he turn to you for help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend's home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).
 

Input
The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with 'X' stands for the lattices of house, and '.' stands for the empty land. The following two lines is the start and end places' coordinates, we guarantee that they are located at 'X'. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.
 

Output
For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.
 

Sample Input
  
  
6 6 ..X... XXX.X. ....X. X..... X..... X.X... 3 5 6 3 0 0
 

Sample Output
  
  
3
Hint
Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).
 

Source
 

Recommend
gaojie
 

Statistic |  Submit |  Discuss |  Note

题意:有一个n*m的地图,还有起点坐标和终点坐标,求从起点到终点的最短时间,走"X"用时为0,走“.”用时为1;

思路:这道题中“X”和“.”的权值不一样,考虑优先队列,其他的和一般广搜一样。

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

struct node
{
    int x;
    int y;
    int s;
    friend bool operator<(node a,node b)//按步数多少排序
    {
        return a.s > b.s;
    }
};

int dir[4][2]= {0,1,1,0,0,-1,-1,0};
char mp[1100][1100];
int book[1100][1100];
int m,n,ex,ey,sx,sy;

void bfs()
{
    node tmp,now;
    priority_queue<node> q;
    now.x = sx;
    now.y = sy;
    now.s = 0;
    book[sx][sy]=1;
    q.push(now);
    while(!q.empty())
    {
        now=q.top();
        q.pop();

        if( now.x == ex && now.y == ey )
        {
            printf("%d\n",now.s);
            return;
        }
        for( int i=0 ; i<4; i++ )
        {
            int tx = now.x + dir[i][0];
            int ty = now.y + dir[i][1];
            if( tx>=0 && ty>=0 && tx<m && ty<n && book[tx][ty]==0 )
            {
                if( mp[tx][ty] == 'X' )//走X权值为0
                    tmp.s = now.s;
                else
                    tmp.s = now.s + 1;//走.权值为1;
                book[tx][ty] = 1;
                tmp.x = tx;
                tmp.y = ty;
                q.push(tmp);
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&m,&n)&&n+m)
    {
        int i,j,k;
        memset(book,0,sizeof(book));
        for( i=0 ; i<m ; i++ )
            scanf("%s",mp[i]);
        scanf("%d%d",&sx,&sy);
        scanf("%d%d",&ex,&ey);
        sx-=1;
        sy-=1;
        ex-=1;
        ey-=1;
        bfs();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值