SimpleSearching

Description

A string is called circle string if it is the same as its reverse. Now write a program to judge whether the string is a circle string.

正读和反读都相同的字符串称为回文。编写程序判断输入的字符串是否回文。

Input Format

A string whose length is less than 100.

Output Format

"yes" if the input string is a circle string.

"no X" if the input string is not a circle string, and X is the first character that does not satisfy the circling condition (从左到右,第一个不满足回文条件的字符).

For example:

"yes" (abcbc is a circling string)

"no c" (accba is not a cicling string, and c is the first character that violates the circling condition).

Sample Input 1

abcba

Sample Output 1

yes

Sample Input 2

accba

Sample Output 2

no c

 

 

#include<stdio.h>
#include <ctype.h>
#include <string.h>
int main()
{
 int ll,f=0,last;
 char s[101];
 scanf("%s",&s);
 ll=strlen(s);last=ll-1;
 if(ll%2==0)
 {
 for(f=0;f<=ll/2;f++)
 {
	if(s[f]==s[last])
		last--;
	else if(s[f]!=s[last])
	 {
	 printf("no ");
	 printf("%c",s[f]);
	 break;
	 }
	
 } 
 if(f==ll/2+1)
	 printf("yes");
 
 }
 else
 {
  for(f=0;f<=(ll-1)/2;f++)
  {
  
  if(s[f]==s[last])
		last--;
	else if(s[f]!=s[last])
	 {
	 printf("no ");
	 printf("%c",s[f]);
	 break;
	 }
  }
 if(f==(ll-1)/2+1)
	 printf("yes");


 }
  return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值