sicily1822 Fight club(dp)

黑书1.5.1例题3
1822 . Fight Club
Description
Fight club is an organization where you release your pressure and emotion by fighting the other club members. The fight begins like this: n people standing in a circle. Then two adjacent guys are chosen to fight. The winner will stay and the loser will be sent to the hospital (there is no tie in the fighting). The cruel fight continues until there is only one left.
It is somewhat strange to see that when two guys fight each other, the result is always definite, and you know the result of every pair of fighters. Though they enjoy fighting, they still want to be the winner. You are to tell each of them, if the fight is arranged properly, can he be the winner.
Input
First line contains integer T (T<=5), the number of test cases.
For each test case, the first line contains n (1<=n<=40), the number of people. Following is the description of a n*n matrix A. Following n lines each contains n ‘0’ or ‘1’, separated by a single blank. The ith number in jth line indicates the fighting result of ith and jth fighter. If it is ‘1’, then the ith fighter will always beat the jth fighter, otherwise he will always lose. You can safely assume that aij and aji are different and aii=0 for every distinct i and j.
The people are numbered counterclockwise.
Output
For each test case, output n lines. If the ith fighter can be the survivor, output 1, otherwise output 0.
Output a blank line after each test case.
Sample Input
2
2
0 1
0 0
3
0 1 1
0 0 1
0 0 0
Sample Output
1
0

1
0
0

题意: 一群人决斗, 给出一个人与另一个人决斗的胜负关系, 问最终每一个人是否有可能胜利.
解题思路:
1. 假设判断第i人是否可以胜出, 将第i人拆成2个人, 可以得出, 只要第i人能够与自己相遇,那么第i人就可以胜利.
2. 设dp[i][j]表示第i人是否可以与第j人相遇, f[i][j]表示第i人与第j的决斗胜负关系.状态转移方程为:
(1).dp[i][j] = 1,if dp[i][k]&&dp[k][j]&&(f[i][k]||f[j][k])
(2).else dp[i][j] = 0;
3. 因为n个人围成一个圆, 我们可以扩大一倍人数, 方便计算i 等价 i+n;
ps:我觉得题目叙述有问题啊,应该是the jth number in ith line indicates the fighting result of ith and jth fighter.
这个sicily貌似是zsdx的校内oj。。我并没有找到能提交的地方。。所以就只好把只过了样例的程序扔这儿了。。要是哪位神犇有数据发现我写错了,请私信我。。不胜感激~~(>_<)~~。

#include <cstdio>
#include <cstring>
#define N 45
int tst,n;
bool f[N][N],dp[N<<1][N<<1];
int main(){
    freopen("a.in","r",stdin);
    scanf("%d",&tst);
    while(tst--){
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
            for(int j=1;j<=n;++j) scanf("%d",&f[i][j]);
        for(int i=1;i<=n;++i) f[0][i]=f[n][i],f[i][0]=f[i][n];
        memset(dp,0,sizeof(dp));
        for(int i=1;i<n*2;++i) dp[i][i+1]=1;
        for(int l=2;l<=n;++l)
            for(int i=1;i<=n*2-l;++l){
                int j=i+l;
                for(int k=i+1;k<j;++k){
                    if(dp[i][k]&&dp[k][j]&&(f[i%n][k%n]||f[i%n][k%n])){
                        dp[i][j]=1;break;
                    }
                }
            }
        for(int i=1;i<=n;++i){
            if(dp[i][i+n]) puts("1");
            else puts("0");
        }
        puts("");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值