1086 Tree Traversals Again (25 分)【前序中序转为后序】

41 篇文章 0 订阅
21 篇文章 0 订阅

 

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题意:就是根据pop实现的是中序遍历,按照压入的栈中的顺序是先序遍历,最后按照后序遍历打印出来

解题思路:利用之前的先序中序转为后序的模板,然后在主函数中将数据稍做处理就行。pop的是中序遍历,push是先序遍历,因为题目没有说明下标不重复,所以需要用value数组保存输入的值(不这样考虑只有9分),根据字符串的长度可以判断是push还是pop,具体的见代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<stack>
#include<cstring>
using namespace std;

vector<int>in,pre,post,value;
int n;

//套模板
void postTravel(int root,int start,int end)
{
	if(start>end)
	return ;
	int i=start;
	while(i<end&&in[i]!=pre[root]) i++;
	postTravel(root+1,start,i-1);
	postTravel(root+1+i-start,i+1,end); 
	post.push_back(value[pre[root]]);
}

int main(void)
{
	scanf("%d",&n);
	stack<int>s;
	char input[7];
	int index=0,a;
	for(int i=1;i<=2*n;i++)
	{
		scanf("%s",input);
		if(strlen(input)==4)
		{
            scanf("%d",&a);
            value.push_back(a);      
		    pre.push_back(index);
			s.push(index++);
		}else{
			in.push_back(s.top());
			s.pop();
		}	
	}
	postTravel(0,0,n-1);
	for(int i=0;i<n;i++)
	printf("%d%s",post[i],i==n-1?"\n":" ");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值