POJ 2965The Pilots Brothers' refrigerator

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4


A的代码:

#include<iostream>
using namespace std;
bool chess[4][4] = { false };//表示全为 ‘+’  即关门
bool flag = false;//用于保存是否全部都为 ‘-’ 即开门
int step = 0;//变换棋子的个数
int arr[17][2] = { -1 };
//判断是否为开门
bool JudgeAll()
{
for (int i = 0; i < 4; i++)
{
for (int j = 0; j < 4; j++)
{
if (!chess[i][j])
return false;
}
}
return true;
}


//变换这一行和这一列的棋子
void change(int row, int col)
{
for (int i = 0; i < 4; i++)
{
chess[row][i] = !chess[row][i];
chess[i][col] = !chess[i][col];
}
chess[row][col] = !chess[row][col];
}


//dfs深度遍历
void dfs(int row, int col, int deep)
{
if (deep == step)
{
flag = JudgeAll();
return;
}
if (flag == true || row == 4 || col == 4)
{
deep++;
return;
}
change(row, col);
arr[deep][0] = row;
arr[deep][1] = col;
if (col < 3)
{
dfs(row, col + 1, deep + 1);
}
else
{
dfs(row + 1, 0, deep + 1);
}
change(row, col);
if (col < 3)
{
dfs(row, col + 1, deep);
}
else
{
dfs(row + 1, 0, deep);
}
return;
}
int main()
{
char a[4][4];
for (int i = 0; i < 4; i++)
{
for (int j = 0; j < 4; j++)
{
cin >> a[i][j];
if (a[i][j] == '-')
chess[i][j] = true;
else
chess[i][j] = false;
}
}
for (step = 0; step <= 16; step++)
{
dfs(0, 0, 0);
if (flag)break;
}
if (flag)
{
cout << step << endl;
for (int i = 0; i < step; i++)
{
for (int j = 0; j < 2; j++)
{
cout << arr[i][j] + 1 << ' ';
}
cout << endl;
}
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值