POJ--1251--Jungle Roads


Jungle Roads Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
 

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30
 
   
 
   
题意:求丛林中所有点都连通时所需的最小花费,即构造最小生成树。
 
   
思路:用 Kruskal 或 prim 算法构造最小生成树(将字符处理成字符串输入)
 
   
代码如下:
Kruskal:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
int flag[100], n;
struct node
{
	int s, d, c;
}road[100];
bool cmp(const node& a, const node& b)
{
	return a.c<b.c;
}
void init()
{
	for(int i=0; i<n; i++)//下标从0 开始
		flag[i]=i;        //初始化根节点为其本身下标
}
int find(int x)//找该点所属的集合的根节点
{
	return x==flag[x] ? x : flag[x]=find(flag[x]);
}
using namespace std;
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int i, j, k, p, w;
	char s[3], d[3];
	while(scanf("%d", &n)){
		if(n==0) break;
		j=n-1;     p=0;
		while(j--){	 
			scanf("%s %d", s, &k);
			while(k--){
				scanf("%s %d", d, &w);
				road[p].s=s[0]-'A';
				road[p].d=d[0]-'A';
				road[p++].c=w;
		 }
		}
		sort(road, road+p, cmp);
		init();
		int num=0, cost=0;
		for(i=0;i<p;i++){
			int L=find(road[i].s), R=find(road[i].d);
			if(L != R){
				num++;
				flag[L]=R;
				cost+=road[i].c;
			}
			if(num==n-1)  break;
		}
		printf("%d\n", cost);
	}
	return 0;
}

prim:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
int nearvex[300], lowest[300], road[300][300], n;
int prim(int u)
{
	int i, j, k, min, cost=0;
	for(i=0;i<n;i++){//顶点下标从0开始
		lowest[i]=road[u][i];
		nearvex[i]=u;//距离i的前一节点
	}
	nearvex[u]=-1;//-1表示已经该点已加入的最小生成树
	for(i=1;i<n;i++){//再加 (n-1) 个点(每次在未加入最小生成树的点集中找距离树点集的最小值)
		min=INF, k=-1;
		for(j=0;j<n;j++){
			if(nearvex[j] != -1&&lowest[j]<min){
				min=lowest[j];  k=j;
			}
		}
		if(k != -1){
			nearvex[k]=-1;
			cost+=lowest[k];
			for(j=0;j<n;j++){
				if(nearvex[j] != -1&&road[k][j]<lowest[j])
					lowest[j]=road[k][j];//从k出发更新最小值
			}
		}
	}
	return cost;
}
using namespace std;
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int k, t, w; 
	char u[3], v[3];
	while(scanf("%d", &n)){
		if(n==0)  break;
		memset(road, INF, sizeof(road));
		k=n-1;
		while(k--){
			scanf("%s %d", u, &t);//将字符当成字符串读入
			while(t--){
				scanf("%s %d", v, &w);
				road[u[0]-'A'][v[0]-'A']=w;//无向路(2条)
				road[v[0]-'A'][u[0]-'A']=w;
			}
		}  
		int ans=prim(0);
		printf("%d\n", ans);
	}
	return 0;
} 

Stkcd [股票代码] ShortName [股票简称] Accper [统计截止日期] Typrep [报表类型编码] Indcd [行业代码] Indnme [行业名称] Source [公告来源] F060101B [净利润现金净含量] F060101C [净利润现金净含量TTM] F060201B [营业收入现金含量] F060201C [营业收入现金含量TTM] F060301B [营业收入现金净含量] F060301C [营业收入现金净含量TTM] F060401B [营业利润现金净含量] F060401C [营业利润现金净含量TTM] F060901B [筹资活动债权人现金净流量] F060901C [筹资活动债权人现金净流量TTM] F061001B [筹资活动股东现金净流量] F061001C [筹资活动股东现金净流量TTM] F061201B [折旧摊销] F061201C [折旧摊销TTM] F061301B [公司现金流1] F061302B [公司现金流2] F061301C [公司现金流TTM1] F061302C [公司现金流TTM2] F061401B [股权现金流1] F061402B [股权现金流2] F061401C [股权现金流TTM1] F061402C [股权现金流TTM2] F061501B [公司自由现金流(原有)] F061601B [股权自由现金流(原有)] F061701B [全部现金回收率] F061801B [营运指数] F061901B [资本支出与折旧摊销比] F062001B [现金适合比率] F062101B [现金再投资比率] F062201B [现金满足投资比率] F062301B [股权自由现金流] F062401B [企业自由现金流] Indcd1 [行业代码1] Indnme1 [行业名称1] 季度数据,所有沪深北上市公司的 分别包含excel、dta数据文件格式及其说明,便于不同软件工具对数据的分析应用 数据来源:基于上市公司年报及公告数据整理,或相关证券交易所、各部委、省、市数据 数据范围:基于沪深北证上市公司 A股(主板、中小企业板、创业板、科创板等)数据整理计算
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值