POJ -- 1201--Intervals (差分约束系统)



 Intervals
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

题意:要求在给出的 n 个区间中,每个区间 [a, b] 至少取 c 个数,问满足要求的集合中元素个数

           最少是多少?

分析:dis[x+1] => 0--x 中有 dis[x+1] 个满足条件的

            2 个式子:dis[b+1] - dis[a] >= c

            0 <= dis[u+1] - dis[u] <= 1 => dis[u+1] - dis[u] >= 0  and dis[u] - dis[u+1] >= -1.

代码如下:

1:用 vector 建边 (时间太长了 1766 ms)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
#define ll unsigned long long 
#define inf 0x3f3f3f3f
#define N 50005
int vis[N],dis[N];
struct r
{
	int v, w;
}tmp;
vector<r> p[N];
void spfa(int mi)
{
	memset(vis,0,sizeof(vis));
	memset(dis,-inf,sizeof(dis));
	queue<int> q;
	q.push(mi);
	vis[mi]=1;
	dis[mi]=0;
	while(!q.empty()){
		int out=q.front(); q.pop();
		vis[out]=0;
		for(int i=0;i<p[out].size();i++){
			if(dis[p[out][i].v]<dis[out]+p[out][i].w){//求最长路
				dis[p[out][i].v]=dis[out]+p[out][i].w;
				if(!vis[p[out][i].v]){
					q.push(p[out][i].v);
					vis[p[out][i].v]=1;
				}
			}
		}
	}
}
int main()
{
#ifdef yibin
	freopen("in.txt","r",stdin);
#endif
	int t, n, m, i, j, k, a, b, c;
	while(~scanf("%d", &t))
	{
		int mi=inf, ma=-inf;
		while(t--){
			scanf("%d%d%d",&a, &b, &c);
			mi=min(mi, a);
			ma=max(ma, b+1);
			tmp.v=b+1, tmp.w=c;//dis[b+1]-dis[a]>=c
			p[a].push_back(tmp);
		}
		//0<=dis[u+1]-dis[u]<=1
		for(i=mi;i<=ma;i++){
			tmp.v=i+1, tmp.w=0;
			p[i].push_back(tmp);//dis[u+1]-dis[u]>=0
			tmp.v=i, tmp.w=-1;
			p[i+1].push_back(tmp);//dis[u]-dis[u+1]>=-1
		}
		spfa(mi);
		printf("%d\n",dis[ma]);
	}
	return 0;
}

2:改用前向星建边 (时间明显减少了 共 344ms(C++)250ms ( G++ ))

   (就是数组要开至少 3 倍,小了一直 RE, 不太懂!)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define N 50005*3//!数组注意开至少 3 倍!
int vis[N], dis[N], head[N], k;
struct r
{
	int v, w, next;
}p[N];
void add(int u, int v, int w)//前向星建边
{
	p[k].v = v;
	p[k].w = w;
	p[k].next = head[u];
	head[u] = k++;
}
void spfa(int mi)
{
	memset(vis, 0, sizeof(vis));
	memset(dis, -inf, sizeof(dis));
	queue<int> q;
	q.push(mi);
	vis[mi] = 1;
	dis[mi] = 0;
	while (!q.empty()){
		int out = q.front(); q.pop();
		vis[out] = 0;
		for (int i = head[out]; i + 1; i = p[i].next){
			if (dis[p[i].v] < dis[out] + p[i].w){//求最长路
				dis[p[i].v] = dis[out] + p[i].w;
				if (!vis[p[i].v]){
					q.push(p[i].v);
					vis[p[i].v] = 1;
				}
			}
		}
	}
}
int main()
{
#ifdef OFFLINE
	freopen("t.txt", "r", stdin);
#endif
	int t, n, m, i, j, a, b, c;
	while (~scanf("%d", &t))
	{
		int mi = inf, ma = -inf, k = 0;
		memset(head, -1, sizeof(head));
		while (t--){
			scanf("%d%d%d", &a, &b, &c);
			mi = min(mi, a);
			ma = max(ma, b + 1);
			add(a, b + 1, c);//dis[b+1]-dis[a]>=c
		}
		//0<=dis[u+1]-dis[u]<=1
		for (i = mi; i <= ma; i++){
			add(i, i + 1, 0);//dis[u+1]-dis[u]>=0
			add(i + 1, i, -1);//dis[u]-dis[u+1]>=-1
		}
		spfa(mi);
		printf("%d\n", dis[ma]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值