Prime Ring Problem


A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


输入

n (0 < n < 20).

输出

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

样例输入

6
8

样例输出

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include <stdio.h>
#include <string.h>
#define mem(a,b) memset(a,b,sizeof(a))
int prime[100]= {1,1};
int a[50],md[50],n;
void sushu()
{
    int i,j;
    for(i=2; i<=10; i++)
        if(prime[i]==0)
            for(j=2*i; j<=50; j+=i)
                prime[j]=1;
}
void dfs(int step)
{
    int i,j;
    if(step==n+1&&prime[a[n]+a[1]]==0)
    {
        for(i=1; i<n; i++)
            printf("%d ",a[i]);
        printf("%d\n",a[n]);
        return;
    }
    for(i=2; i<=n; i++)
    {
        if(md[i]==0&&prime[i+a[step-1]]==0)
        {
            a[step]=i;
            md[i]=1;
            dfs(step+1);
            md[i]=0;
        }
    }
    return;

}
int main()
{
    int num=1;
    a[1]=1;
    sushu();
    while(~scanf("%d",&n))
    {
        mem(md,0);
        printf("Case %d:\n",num++);
        dfs(2);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值