POJ1014:Dividing<动归,背包问题>

1014:Dividing

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
输入
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.
输出
For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.
样例输入
1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 
样例输出
Collection #1:
Can't be divided.

Collection #2:
Can be divided.
来源

Mid-Central European Regional Contest 1999


背包算法

#include <cstdio>
#include <algorithm>
#include<memory.h>
using namespace std;
int dp[6*20001];
int main()
{
    int n[7], Case = 1;
    while (1) {
        // Input
        int sum = 0;
        for (int i = 1; i <= 6; ++i) {
            scanf("%d", &n[i]);
            sum += (i*n[i]);
        }
        if (!sum) break;
        printf("Collection #%d:\n", Case++);
        
        // Knapsack
        if (sum & 1) puts("Can't be divided.\n");//按位‘&’太机智
        else {
            sum /= 2;
            fill(dp, dp+sum+1, 0);//分成二进制。
            for (int i = 1; i <= 6; ++i) {
                int left = n[i];
                for (int j = 1; j <= left; left -= j, j *= 2)
                    for (int k = sum; k - i*j >= 0; --k)
                        dp[k] = max(dp[k], dp[k-i*j] + i*j);
                for (int j = 0; j < left; ++j)   //
                    for (int k = sum; k - i >= 0; --k)
                        dp[k] = max(dp[k], dp[k-i] + i);
            }
            if (dp[sum] == sum) puts("Can be divided.\n");
            else puts("Can't be divided.\n");
        }
    }
    return 0;
}
这是dfs的版本

#include<iostream>
using namespace std;
int n[7];  //价值为i的物品的个数
int SumValue;  //物品总价值
int HalfValue;  //物品平分价值
bool flag;    //标记是否能平分SumValue
void DFS(int value,int pre)
{
    if(flag)
        return;
    if(value==HalfValue)
    {
        flag=true;
        return;
    }
    
    for(int i=pre;i>=1;i--)
    {
        if(n[i])
        {
            if(value+i<=HalfValue)
            {
                n[i]--;
                DFS(value+i,i);
                if(flag)
                    break;
            }
        }
    }
    return;
}
int main(int i)
{
    int test=1;
    while(cin>>n[1]>>n[2]>>n[3]>>n[4]>>n[5]>>n[6])
    {
        SumValue=0;  //物品总价值
        for(i=1;i<=6;i++)
            SumValue+=i*n[i];
        if(SumValue==0)
            break;
        if(SumValue%2)    //sum为奇数,无法平分
        {
            cout<<"Collection #"<<test++<<':'<<endl;
            cout<<"Can't be divided."<<endl<<endl;    //注意有空行
            continue;
        }
        HalfValue=SumValue/2;
        flag=false;
        DFS(0,6);
        if(flag)
        {
            cout<<"Collection #"<<test++<<':'<<endl;
            cout<<"Can be divided."<<endl<<endl;
            continue;
        }
        else
        {
            cout<<"Collection #"<<test++<<':'<<endl;
            cout<<"Can't be divided."<<endl<<endl;
            continue;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值