Seaside(Floyd)

Seaside

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 32 Accepted Submission(s) : 29
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the i-th town and the SMi town is LMi.
Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
Sample Input
5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1
Sample Output
2
Source
2010 Asia Regional Harbin

简单的floyd暴力算法

//在小镇0,求到海边的最短距离。典型的floyd
#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>
#include<cstdio>
//#include<map>
using namespace std;
#define INF 99699699
int map[20][20];
int n;
int main()
{
    int p, num,to,l;
    while (cin >> n)
    {
        for (int i = 0;i <= n;i++)
        {
            for (int j = 0;j <= n;j++)
            {
                map[i][j] = INF;
                if (i == j)
                    map[i][j] = 0;
            }
        }
        for (int k = 0;k < n;k++)
        {
            cin >> p >> num;
            if (num)
                map[k][n] = 0;
            for (int j = 0;j < p;j++)
            {
                cin >> to >> l;
                map[k][to] = l;
            }
        }
        for (int i = 0;i <= n;i++)
        {
            for (int j = 0;j <= n;j++)
            {
                for (int k = 0;k <= n;k++)
                {
                    if (map[i][j] > map[i][k] + map[k][j])
                    {
                        map[i][j] = map[i][k] + map[k][j];
                    }
                }
            }
        }
        cout << map[0][n] << endl;
    }
    return 0;
}
这里写代码片
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值