Graph Theory
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 0 Accepted Submission(s): 0
Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called “Cool Graph”, which are generated in the following way:
Let the set of vertices be {1, 2, 3, …, n}. You have to consider every vertice from left to right (i.e. from vertice 2 to n). At vertice i, you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to i−1).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ”Cool Graph” has perfect matching. Please write a program to help him.
Input
The first line of the input contains an integer T(1≤T≤50), denoting the number of test cases.
In each test case, there is an integer n(2≤n≤100000) in the first line, denoting the number of vertices of the graph.
The following line contains n−1 integers a2,a3,…,an(1≤ai≤2), denoting the decision on each vertice.
Output
For each test case, output a string in the first line. If the graph has perfect matching, output ”Yes”, otherwise output ”No”.
Sample Input
3
2
1
2
2
4
1 1 2
Sample Output
Yes
No
No
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<string>
#include<iomanip>
#include<cmath>
#define ll long long int
#define maxsize 105000
#define INF 99999999
using namespace std;
int a[maxsize];
int main()
{
int t;int n;
while (cin >> t)
{
while (t--)
{
int sum = 0;
cin >> n;int flag = 0;
for (int i = 2;i <= n;i++)
{
cin >> a[i];
if (a[i] == 1)
{
if (sum<i-1)
{
sum += 2;
}
}
}
if (n % 2)
{
cout << "No" << endl;
}
else
{
if (sum == n)
cout << "Yes" << endl;
else
cout << "No" << endl;
}
}
}
return 0;
}