1084. Broken Keyboard (20)(PAT甲)

  1. Broken Keyboard (20)
    时间限制
    200 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue
    On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or “_” (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI

一开始忽略了例如ab与a这样的样例,不够仔细= =

AC代码:

#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    string str;
    string bstr;
    while (cin>>str>>bstr)
    {

        string ans;
        //getline(cin, bstr);
        int t = 0, l1, l2, sum = 0;
        l1 = str.length();
        l2 = bstr.length();
        for (int i = 0; i < l1; i++)//预处理小写字母变成大写字母
        {
            if (str.at(i) >= 'a'&&str.at(i) <= 'z')
            {
                str.at(i) -= 32;
            }
        }
        for (int i = 0; i < l2; i++)//预处理小写字母变成大写字母
        {
            if (bstr.at(i) >= 'a'&&bstr.at(i) <= 'z')
            {
                bstr.at(i) -= 32;
            }
        }
        for (int i = l2; i < l1; i++)//用于特殊情况以维护
        {
            bstr += str;
        }
        for (int i = 0; i < l1; i++)
        {

                if (str.at(i) != bstr.at(t + i))
                {
                    t--; bool flag = 0;//判断这个字符之前是否出现过
                    for (int j = 0; j < i; j++)
                    {
                        if (!i) break;
                        if (str.at(i) == str.at(j))
                        {
                            flag = 1;
                            break;
                        }
                    }
                    if (!flag)
                    {
                        ans += str.at(i);
                    }
                }


        }
        cout << ans << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值