The 18th Zhejiang University Programming Contest Sponsored by TuSimple - F【DP】

题面:http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5737
Schrödinger’s Knapsack
Time Limit: 1 Second Memory Limit: 131072 KB
DreamGrid has a magical knapsack with a size capacity of called the Schrödinger’s knapsack (or S-knapsack for short) and two types of magical items called the Schrödinger’s items (or S-items for short). There are S-items of the first type in total, and they all have a value factor of ; While there are S-items of the second type in total, and they all have a value factor of . The size of an S-item is given and is certain. For the -th S-item of the first type, we denote its size by ; For the -th S-item of the second type, we denote its size by .

But the value of an S-item remains uncertain until it is put into the S-knapsack (just like Schrödinger’s cat whose state is uncertain until one opens the box). Its value is calculated by two factors: its value factor , and the remaining size capacity of the S-knapsack just after it is put into the S-knapsack. Knowing these two factors, the value of an S-item can be calculated by the formula .

For a normal knapsack problem, the order to put items into the knapsack does not matter, but this is not true for our Schrödinger’s knapsack problem. Consider an S-knapsack with a size capacity of 5, an S-item with a value factor of 1 and a size of 2, and another S-item with a value factor of 2 and a size of 1. If we put the first S-item into the S-knapsack first and then put the second S-item, the total value of the S-items in the S-knapsack is ; But if we put the second S-item into the S-knapsack first, the total value will be changed to . The order does matter in this case!

Given the size of DreamGrid’s S-knapsack, the value factor of two types of S-items and the size of each S-item, please help DreamGrid determine a proper subset of S-items and a proper order to put these S-items into the S-knapsack, so that the total value of the S-items in the S-knapsack is maximized.

Input
The first line of the input contains an integer (about 500), indicating the number of test cases. For each test case:

The first line contains three integers , and (), indicating the value factor of the first type of S-items, the value factor of the second type of S-items, and the size capacity of the S-knapsack.

The second line contains two integers and (), indicating the number of the first type of S-items, and the number of the second type of S-items.

The next line contains integers (), indicating the size of the S-items of the first type.

The next line contains integers (), indicating the size of the S-items of the second type.

It’s guaranteed that there are at most 10 test cases with their larger than 100.

Output
For each test case output one line containing one integer, indicating the maximum possible total value of the S-items in the S-knapsack.

Sample Input
3
3 2 7
2 3
4 3
1 3 2
1 2 10
3 4
2 1 2
3 2 3 1
1 2 5
1 1
2
1
Sample Output
23
45
10
Hint
For the first sample test case, you can first choose the 1st S-item of the second type, then choose the 3rd S-item of the second type, and finally choose the 2nd S-item of the first type. The total value is .

For the second sample test case, you can first choose the 4th S-item of the second type, then choose the 2nd S-item of the first type, then choose the 2nd S-item of the second type, then choose the 1st S-item of the second type, and finally choose the 1st S-item of the first type. The total value is .

The third sample test case is explained in the description.

It’s easy to prove that no larger total value can be achieved for the sample test cases.

给你两种物品,每一种物品的价值相同,但是重量不同。
给你一个背包,让你取最大值。每加入一个元素,增值为物品的价值乘以背包剩余空间。
求最大值。

显然,同一种物品中,先入质量小的,所获的收获是最大的。那么有两种物品的话,我们实际上可以改成二维DP,dp[i][j]是第一种物品取到i个,第二个物品取到j个的最大价值,就ojbk了。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define ll long long int
#define INF 0x3f3f3f3f
const int maxn = 2e3 + 10;
int a[maxn];
int b[maxn];
int sa[maxn];
int sb[maxn];
ll dp[maxn][maxn];
int main()
{
    int T;
    scanf("%d", &T);
    while (T--) {
        int k1, k2, c;
        scanf("%d%d%d", &k1, &k2, &c);
        int n, m;
        scanf("%d%d", &n, &m);
        dp[0][0] = 0;
        for (int i = 0; i <= n; i++) {
            for (int j = 0; j <= m; j++) {
                dp[i][j] = 0;
            }
        }
        memset(sa, 0, sizeof a);
        memset(sb, 0, sizeof b);
        for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
        for (int i = 1; i <= m; i++) scanf("%d", &b[i]);
        sort(a + 1, a + 1 + n); sort(b + 1, b + 1 + m);
        for (int i = 1; i <= n; i++) sa[i] = sa[i - 1] + a[i];
        for (int i = 1; i <= m; i++) sb[i] = sb[i - 1] + b[i];
        if (c - sa[1] >= 0) dp[1][0] = 1ll * k1 * (c - sa[1]);
        if (c - sb[1] >= 0) dp[0][1] = 1ll * k2 * (c - sb[1]);
        ll ans = max(dp[1][0], dp[0][1]);
        for (int i = 0; i <= n; i++) {
            for (int j = 0; j <= m; j++) {
                if (sa[i] + sb[j] > c) break;
                if ((i-1)>=0&&dp[i - 1][j]) {
                    dp[i][j] = max(dp[i][j], dp[i - 1][j] + 1ll*k1 * (c - sa[i] - sb[j]));
                }
                if ((j-1>=0)&&dp[i][j - 1]) {
                    dp[i][j] = max(dp[i][j], dp[i][j - 1] + 1ll*k2 * (c - sa[i] - sb[j]));
                }
                ans = max(ans, dp[i][j]);

            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值