HDU2196 Computer树形dp

Problem Description

A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.
img

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input

5
1 1
2 1
3 1
1 1

Sample Output

3
2
3
4
4

​ 翻译成汉语,就是给你n个点,再给n - 1行每行两个整数a, b,代表第i个电脑和a相连距离为b。最后输出每台电脑距离最远电脑的距离

思路:

​ 这题我们可以把图转化为树,可以说是树形dp吧。我们通过第一遍dfs由叶到根递归计算每个节点作为根节点的子树中,与该节点距离最远和次远的距离与儿子节点。再通过第二遍dfs由根到叶递归计算每个节点往上走(非该子树)节点的最长距离。最后我们遍历每个节点,只需要比较该节点作为根节点的子树中的最长距离与往上走的最大值,取较大值即为答案。

代码:

#include <stdio.h>
#include <vector>
#include <algorithm>
#include <string.h>
#define N 10005
#define mem(a) memset(a, 0, sizeof(a));
using namespace std;

struct node {
    int son, val;
};

struct gold {
    int maxx, son;
};

int n;
vector<node>point[N];
gold maxn[N][3];  //0最大值 1次大值 2父最大值
int pre[N];

void init() {
    int a, b;
    node c;
    mem(maxn);
    for (int i = 1; i <= n; i++) {
        pre[i] = i;
        point[i].clear();
    }
    for (int i = 2; i <= n; i++) {
        scanf("%d%d", &a, &b);
        pre[i] = a;
        c.son = i;
        c.val = b;
        point[a].push_back(c);
    }
}

void dfs(int inx) {
    for (int i = 0; i < point[inx].size(); i ++) {
        node son = point[inx][i];
        dfs(son.son);
        if(maxn[inx][0].maxx < son.val + maxn[son.son][0].maxx) {
            maxn[inx][1].maxx = maxn[inx][0].maxx;
            maxn[inx][1].son = maxn[inx][0].son;
            maxn[inx][0].maxx = son.val + maxn[son.son][0].maxx;
            maxn[inx][0].son = son.son;
        } else if(maxn[inx][1].maxx < son.val + maxn[son.son][0].maxx) {
            maxn[inx][1].maxx = son.val + maxn[son.son][0].maxx;
            maxn[inx][1].son = son.son;
        }
    }
}

void dfs1(int inx) {
    int father = pre[inx];
    if(inx != 1) {
        int t;
        for(int i = 0; i < point[father].size(); i++) {
            if(point[father][i].son == inx) {
                t = point[father][i].val;
                break;
            }
        }
        if(maxn[father][0].son == inx) {
            maxn[inx][2].son = father;
            maxn[inx][2].maxx = t + max(maxn[father][1].maxx, maxn[father][2].maxx);
        } else {
            maxn[inx][2].son = father;
            maxn[inx][2].maxx = t + max(maxn[father][0].maxx, maxn[father][2].maxx);
        }
    }
    for (int i = 0; i < point[inx].size(); i++) {
        dfs1(point[inx][i].son);
    }
}

int main () {
    while (scanf("%d", &n) == 1) {
        int ans;
        init();
        dfs(1);
        dfs1(1);
        for (int i = 1; i <= n; i++) {
            ans = max(maxn[i][0].maxx, maxn[i][2].maxx);
            printf("%d\n", ans);
        }
    }
    return 0;
}

转载请注明出处!!!

如果有写的不对或者不全面的地方 可通过主页的联系方式进行指正,谢谢

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值