AtCoder-Contest-122-D-We-Like-AGC

Problem Statement

You are given an integer N. Find the number of strings of length N that satisfy the following conditions, modulo 109+7:

  • The string does not contain characters other than A, C, G and T.
  • The string does not contain AGC as a substring.
  • The condition above cannot be violated by swapping two adjacent characters once.

Notes

A substring of a string T is a string obtained by removing zero or more characters from the beginning and the end of T.

For example, the substrings of ATCODER include TCO, AT, CODER, ATCODER and `` (the empty string), but not AC.

Constraints

  • 3≤N≤100

Input

Input is given from Standard Input in the following format:

N

Output

Print the number of strings of length N that satisfy the following conditions, modulo 109+7.


Sample Input 1

3

Sample Output 1

61

There are 43=64 strings of length 3 that do not contain characters other than A, C, G and T. Among them, only AGC, ACG and GAC violate the condition, so the answer is 64−3=61.


Sample Input 2

Copy

4

Sample Output 2

230

Sample Input 3

100

Sample Output 3

388130742

Be sure to print the number of strings modulo 109+7.

​ 题目大意就是字符串只能由A、C、G、T组成,然后子串中不能出现AGC,还有任意两个相邻的字符交换后不能出现AGC。也就是说排除一下几种情况:

AGC
ACG
GAC
AXGC	//X代表A C G T
AGXC

​ 所以我只需要定义dp[i][j][p][q]代表前i个字符,最后3个字符为j,p,q的方案数(0代表A,1代表C,2代表G,3代表T)。详细见代码

代码:

#include <stdio.h>
#define ll long long
#define mod 1000000007

ll dp[105][4][4][4] = {0};

bool pan(int a, int b, int c) {
    if (a == 0 && b == 2 && c == 1) return false;
    if (a == 0 && b == 1 && c == 2) return false;
    if (a == 2 && b == 0 && c == 1) return false;
    return true;
}

bool pan1(int a, int b, int c) {
    if (a == 0 && b == 2 && c == 1) return false;
    return true;
}

int main () {
    int n;
    scanf("%d", &n);
    if (n == 1) {
        printf("4\n");
    } else if(n == 2) {
        printf("16\n");
    } else {
        for (int i = 0; i < 4; i++) {
            for (int j = 0; j < 4; j++) {
                for (int p = 0; p < 4; p++) {
                    if (pan(i, j, p)) {
                        dp[3][i][j][p] = 1;
                    }
                }
            }
        }

        for (int k = 4; k <= n; k++) {
            for (int i = 0; i < 4; i++) {
                for (int j = 0; j < 4; j++) {
                    for (int p = 0; p < 4; p++) {
                        //dp[k][i][j][p]
                        if (pan(i, j, p)) {
                            for (int q = 0; q < 4; q++) {
                                if (pan(q, i, j) && pan1(q, j, p) && pan1(q, i, p)) {
                                    dp[k][i][j][p] = (dp[k][i][j][p] + dp[k - 1][q][i][j]) % mod;
                                } 
                            }
                        }
                    }
                }
            }
        }

        ll ans = 0;
        for (int i = 0; i < 4; i++) {
            for (int j = 0; j < 4; j++) {
                for (int p = 0; p < 4; p++) {
                    ans = (ans + dp[n][i][j][p]) % mod;
                }
            }
        }
        printf("%lld\n", ans);

    }
    return 0;
}

转载请注明出处!!!

如果有写的不对或者不全面的地方 可通过主页的联系方式进行指正,谢谢

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值