蓝桥杯:回形取数

题目:

回形取数就是沿矩阵的边取数,若当前方向上无数可取或已经取过,则左转90度。一开始位于矩阵左上角,方向向下。
输入格式
  输入第一行是两个不超过200的正整数m, n,表示矩阵的行和列。接下来m行每行n个整数,表示这个矩阵。
输出格式
  输出只有一行,共mn个数,为输入矩阵回形取数得到的结果。数之间用一个空格分隔,行末不要有多余的空格。
样例输入
3 3
1 2 3
4 5 6
7 8 9
样例输出
1 4 7 8 9 6 3 2 5
样例输入
3 2
1 2
3 4
5 6
样例输出
1 3 5 6 4 2


分析:

1.走的路线是下右上左

2.如果已经走过了,那么久设个标记,下次再遇到就换方向.


代码:

#include<iostream>
#include<cstring>

using namespace std;

int main(){
   int m,n;
   cin>>m>>n;
   int a[m][n];
   int i,j;
   for(i=0;i<m;i++){
    for(j=0;j<n;j++){
        cin>>a[i][j];
    }
   }
   int sum=m*n;
   i=-1;j=0;
   while(sum){
    //向下走
    while(a[++i][j]!=-1 && i<m){
        cout<<a[i][j]<<" ";
        a[i][j]=-1;
        sum--;
    }
    i--;
   
   //向右走
    while(a[i][++j]!=-1 && j<n){
        cout<<a[i][j]<<" ";
        a[i][j]=-1;
        sum--;
    }
    j--;
    //向上走
    while(a[--i][j]!=-1 && i>=0){
        cout<<a[i][j]<<" ";
        a[i][j]=-1;
        sum--;
    }
    i++;
    //向左走
    while(a[i][--j]!=-1 && j>=0){
        cout<<a[i][j]<<" ";
        a[i][j]=-1;
        sum--;
    }
    j++;
   }
    return 0;
}


  • 4
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 8
    评论
蓝桥杯是中国最具影响力的计算机竞赛之一,回形取数蓝桥杯中的一道经典题目。下面是关于Python实现回形取数的介绍: 回形取数是指从一个矩阵中按照回形的方式依次取出所有的元素。具体来说,就是从矩阵的左上角开始,按照顺时针的方向依次取出元素,直到取完所有元素为止。 在Python中,可以通过嵌套列表来表示矩阵。下面是一个示例代码,实现了回形取数的功能: ```python def spiral_order(matrix): if not matrix: return [] rows, cols = len(matrix), len(matrix[0]) top, bottom, left, right = 0, rows - 1, 0, cols - 1 result = [] while top <= bottom and left <= right: # 从左到右 for col in range(left, right + 1): result.append(matrix[top][col]) top += 1 # 从上到下 for row in range(top, bottom + 1): result.append(matrix[row][right]) right -= 1 if top <= bottom: # 从右到左 for col in range(right, left - 1, -1): result.append(matrix[bottom][col]) bottom -= 1 if left <= right: # 从下到上 for row in range(bottom, top - 1, -1): result.append(matrix[row][left]) left += 1 return result # 测试 matrix = [[1, 2, 3], [4, 5, 6], [7, 8, 9]] result = spiral_order(matrix) print(result) ``` 以上代码中,`spiral_order`函数接受一个二维列表作为输入,表示矩阵。函数通过设定上下左右四个边界来控制取数的范围,然后按照顺时针的方向依次取出元素,并将其添加到结果列表中。最后返回结果列表。
评论 8
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值