POJ-2299(树状数组)

                                                                  Ultra-QuickSort

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 75430 Accepted: 28242

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,


Ultra-QuickSort produces the output 

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

struct node
{
    int w,i;
};
int a[500001],c[500001],n;
node x[500001];

bool cmp(node x,node y)
{
    return x.w<y.w;
}

int lowbit(int x)
{
    return x&(-x);
}

int sum(int pos)
{
    int s=0;
    while(pos>0)
    {
        s+=c[pos];
        pos-=lowbit(pos);
    }
    return s;
}

void update(int pos,int num)
{
    while(pos<=n)
    {
        c[pos]+=num;
        pos+=lowbit(pos);
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x[i].w);
            x[i].i=i;
        }

        sort(x+1,x+1+n,cmp);
        for(int i=1;i<=n;i++)
            a[x[i].i]=i;

        memset(c,0,sizeof(c));
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            update(a[i],1);
            ans+=i-sum(a[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值