http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5048
Painting Storages
Time Limit: 2 Seconds Memory Limit: 65536 KB
There is a straight highway with N storages alongside it labeled by 1,2,3,...,N. Bob asks you to paint all storages with two colors: red and blue. Each storage will be painted with exactly one color.
Bob has a requirement: there are at least M continuous storages (e.g. "2,3,4" are 3 continuous storages) to be painted with red. How many ways can you paint all storages under Bob's requirement?
Input
There are multiple test cases.
Each test case consists a single line with two integers: N and M (0<N, M<=100,000).
Process to the end of input.
Output
One line for each case. Output the number of ways module 1000000007.
Sample Input
4 3
Sample Output
3
Author: ZHAO, Kui
Contest: ZOJ Monthly, June 2013
Submit Status
Copyright @ 2001-2012, Zhejiang University ACM/ICPC Team, All rig
思路来自:http://blog.csdn.net/dgq8211/article/details/9212243
ZOJ 3725 Painting Storages(DP解排列计数)
分类: ◆点点滴滴 【动态规划】 2013-07-01 11:14 224人阅读 评论(0) 收藏 举报
题目链接:Click here~~
题意:
n个格子排成一条直线,可以选择涂成红色或蓝色,问最少 m 个连续为红色的方案数。
解题思路:
应该是这次 ZOJ 月赛最水的一题,可惜还是没想到。。。
dp[i] 表示前 i 个最少 m 个连续为红色的方案数。
转移时,分类讨论:
1、前 i-1 个已经满足这个性质,那么,第 i 个随意涂色,方案数为 dp[i-1] * 2 。
2、前 i-1 个不满足这个性质,那么,要想成为方案,区间 [i-m+1,i] 必须涂成红色。并且,下标为 i-m 这个点必须是蓝色,否则就与 情况1 重复了。
而且正是由于这一点,只要剩下的区间 [1,i-m-1] 不满足这个性质,就能保证整个区间 [1,i-1] 不满足这个性质。方案数为 2^(i-m-1) - dp[i-m-1]。
f[i]=(f[i-1]*2+2^(i-m-1)-f[i-m-1]);
Ps:个人理解情况2:[1,i-m-1]区间总共有2^(i-m-1)种取法,而又假设了m为蓝色,[i-m+1,i],为红色,故此时【1,i】
区间存在合法可能性为,2^(i-m-1)-f[i-m-1].
*/
#include<stdio.h>
#include<math.h>
#include<string.h>
int mod=1000000007;
const int maxn=100000+5;
int p[maxn],f[maxn];
void init()
{
p[0]=1;
for(int i=1;i<=maxn;i++)
p[i]=p[i-1]*2%mod;
}
int main()
{
int i,n,m;
init();
while(scanf("%d%d",&n,&m)!=EOF)
{ memset(f,0,sizeof(f));
f[m]=1;
for(i=m+1;i<=n;i++)
f[i]=((f[i-1]*2%mod+p[i-m-1]-f[i-m-1])%mod+mod)%mod;//注意这里的取模位置
printf("%d\n",f[n]);
}
return 0;
}