http://poj.org/problem?id=2398
http://acm.hust.edu.cn/vjudge/contest/view.action?cid=29328#problem/E
E - Toy Storage
POJ 2398
Description
Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.
A line consisting of a single 0 terminates the input.
Output
For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0
Sample Output
Box
2: 5
Box
1: 4
2: 1
解析:
题意:
在一个盒子里放上n块板子隔成n+1个小格子,放入m个玩具,给出了玩具及板子的坐标。统计每个格子的玩具个数。并且按照玩具个数t由小到大到的顺序输出以及含有t个玩具的格子数
思路:
向量叉乘+二分查找
1.把玩具看成一个点,板子看成一条线段,先将线段按照横左标由小到大的顺序排列,利用向量叉乘判断点在线段的哪个位置
2.利用二分法找出最靠近该点并且在该点右边的线段,然后记录玩具数
3.将玩具个数排序,然后按要求输出
192 KB 16 ms C++ 1290 B
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=1000+10;
int a[maxn],n,ans[maxn];
struct box
{
int x1,x2;
int y1,y2;
}b[maxn];
struct point
{
int x;
int y;
};
bool cmp1(box A,box B)
{
return A.x1<=B.x1;
}
int Cross(point A,point B)
{
return A.x*B.y-A.y*B.x;
}
point sub(point a,point b)
{
point c;
c.x=a.x-b.x;
c.y=a.y-b.y;
return c;
}
int main()
{ int i,lx,ly,rx,ry;
int m;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
scanf("%d",&m);
scanf("%d%d%d%d",&lx,&ly,&rx,&ry);
for(i=0;i<n;i++)
{
scanf("%d%d",&b[i].x1,&b[i].x2);
b[i].y1=ly;
b[i].y2=ry;
}
b[n].x1=rx;
b[n].y1=ly;
b[n].x2=rx;
b[n].y2=ry;
memset(a,0,sizeof(a));
memset(ans,0,sizeof(ans));
sort(b,b+n+1,cmp1);
for(i=0;i<m;i++)
{
point p;
scanf("%d%d",&p.x,&p.y);
int r,l,mid;
r=n;l=0;
while(l<r)//二分查找
{
mid=(l+r)/2;
point t1,t2;
t1.x=b[mid].x1;
t1.y=b[mid].y1;
t2.x=b[mid].x2;
t2.y=b[mid].y2;
int k=Cross(sub(t1,p),sub(t2,p));
if(k<0)//说明p点在该线段左边
{r=mid;
}
else
l=mid+1;
}
ans[l]++;
}
printf("Box\n");
for(i=0;i<=n;i++)
if(ans[i]>0)
a[ans[i]]++;
for(i=1;i<=n;i++)
if(a[i]>0)
{
printf("%d: %d\n",i,a[i]);
}
}
return 0;
}
/*200 KB 16 ms C++ 1396 B
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=1000+10;
int a[maxn],n,ans[maxn];
struct box
{
int x1,x2;
int y1,y2;
}b[maxn];
struct point
{
int x;
int y;
}p[maxn];
bool cmp1(box A,box B)
{
return A.x1<=B.x1;
}
int Cross(point A,point B)
{
return A.x*B.y-A.y*B.x;
}
point sub(point a,point b)
{
point c;
c.x=a.x-b.x;
c.y=a.y-b.y;
return c;
}
int binarysearch(point p1)//二分查找
{
int r,l,e,mid;
r=n;
l=0;
while(l<=r)
{
mid=(l+r)/2;
point t1,t2;
t1.x=b[mid].x1;
t1.y=b[mid].y1;
t2.x=b[mid].x2;
t2.y=b[mid].y2;
int k=Cross(sub(t1,p1),sub(t2,p1));
//printf("k==%d",k);
if(k<0)
{r=mid-1;
e=mid;
}
else
l=mid+1;
}
return e;
}
int main()
{ int i,lx,ly,rx,ry;
int m;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
scanf("%d",&m);
scanf("%d%d%d%d",&lx,&ly,&rx,&ry);
for(i=0;i<n;i++)
{
scanf("%d%d",&b[i].x1,&b[i].x2);
b[i].y1=ly;
b[i].y2=ry;
}
b[n].x1=rx;
b[n].y1=ly;
b[n].x2=rx;
b[n].y2=ry;
memset(a,0,sizeof(a));
sort(b,b+n+1,cmp1);
memset(ans,0,sizeof(ans));
for(i=0;i<m;i++)
{scanf("%d%d",&p[i].x,&p[i].y);
int id=binarysearch(p[i]);
ans[id]++;
}
printf("Box\n");
for(i=0;i<=n;i++)
if(ans[i]>0)
a[ans[i]]++;
for(i=1;i<=n;i++)
if(a[i]>0)
{
printf("%d: %d\n",i,a[i]);
}
}
return 0;
}
*/