http://acm.hdu.edu.cn/showproblem.php?pid=1196
http://acm.hust.edu.cn/vjudge/contest/view.action?cid=29974#problem/C
Lowest Bit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6453 Accepted Submission(s): 4737
Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
Output
For each A in the input, output a line containing only its lowest bit
Sample Input
26
88
0
Sample Output
2
8
Author
SHI, Xiaohan
Source
Zhejiang University Local Contest 2005
Recommend
Ignatius.L
解析:
题意:
将一个数化为二进制,求出右边第一个开始到出现第一个1形成的十进制数是多少
思路:
1,暴力。先化为二进制,寻找左边出现的第一个的位置,再求解
2.直接用位运算去掉右起第一个1的左边:x&(x^(x-1));
228 KB 15 ms C++ 198 B
*/
#include<stdio.h>
#include<math.h>
#include <iostream>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n!=0)
{
printf("%d\n",(n)&(n^(n-1)));
}
return 0;
}