B - Trie树(字符串问题)

/*
http://acmore.net:8080/contest/view.action?cid=11#problem/B
B - Trie树
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 
Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 
Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#
Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
题意:给出一系列的字典单词;
      再给出一系列查找的单词,从字典词中寻找这个单词,若是这个单词在字典中出现过,则输出该单词是“ is correct”;
      否则,按照字典词里出现的顺序,输出与单词差别只有一个字母的字典词(这里的差别是指,插入或删除或替换一个字母)
思路:刚开始的时候想用字典树来着,可是,找出这种差别的算法,我还没想到。后来看到题目的数据挺小的,于是用暴力法
分类讨论一一比较
以下代码:
364 KB 188 ms C++ 2037 B 2013-04-25 
*/
#include<stdio.h>
#include<string.h>
#include <iostream>
using namespace std;
const int maxn=50000+10;
char dic[maxn][20],word[55][20];
int n,m;
char temp[maxn][20];
int len;
int cmp(char s1[],char s2[])
 {
     int cnt=0;
     int i,j,k;
    int len1=strlen(s1);
     if(len1-len==1)//插入情况
      {
          for(j=0,i=0;j<len1,i<len;j++,i++)
           {
            while(s2[i]!=s1[j]&&j<len1)
           {
               cnt++;
               j++;
           }
           if(cnt>1)
            return cnt;


           }
           if(cnt==0)
           cnt=1;
      }
    else if(len-len1==1)//删除情况
       { for(i=0,j=0;j<len1,i<len;i++,j++)
           {
            while(s2[i]!=s1[j]&&i<len)
           {cnt++;
            i++;
           }
           if(cnt>1)
            return cnt;
           }
           if(cnt==0)
           cnt=1;
       }
      else if(len1==len)//替换情况
       {
       for(i=0;i<len;i++)
           {
            if(s2[i]!=s1[i])
           {cnt++;
           }
           if(cnt>1)
            return cnt;
           }
        }
        else cnt=-1;
       return cnt;
 }
 void work()
  {    int ok,k,t,p;
      for(int i=0;i<m;i++)
        { k=0;
          ok=0;
          len=strlen(word[i]);
         for(int j=0;j<n;j++)
          {p=cmp(dic[j],word[i]);
          //printf("%d ",p);
              if(p==1)
             strcpy(temp[k++],dic[j]);
            if(p==0)
             {
             ok=1;
             break;
             }
          }
          if(ok)
          printf("%s is correct\n",word[i]);
          else
          {printf("%s:",word[i]);
           for(t=0;t<k;t++)
            {   if(t<k)
              printf(" ");
            printf("%s",temp[t]);
            }
            printf("\n");
          }
        }
  }
int main()
{
   n=0;
  m=0;
  int i,j;
  j=i=0;
   for(;;)
    {scanf("%s",dic[i++]);
    if(dic[i-1][0]=='#')
     {n=i-1;
     break;
     }
    }
    for(;;)
    {scanf("%s",word[j++]);
    if(word[j-1][0]=='#')
     {m=j-1;
     break;
     }
    }
    work();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值