D - FatMouse's Speed(最小生成序列+输出)

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing. 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file. 

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. 

Two mice may have the same weight, the same speed, or even the same weight and speed. 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]] 

and 

S[m[1]] > S[m[2]] > ... > S[m[n]] 

In order for the answer to be correct, n should be as large as possible. 
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
8

题意:

很多肥老鼠认为,长的越肥,奔跑速度就越快,为了反驳这个观点,你现在需要对老鼠的体重和速度进行研究,

你要在老鼠序列中找出一个子序列,使得老鼠的体重在增加,但是速度却在减慢 

转化成去找最长子序列问题(满足体重增加,速度减少)

用结构体,然后按体重增加或者速度减少的方式排序,去找最长子序列的长度

然后重点重点重点就是输出哪几个老鼠的问题!!!!

用一个标记数组 pre[]  ,标记当前点的 dp 是从哪一点增加而来的,然后倒序输出 pre[] 

这个题真的很气人,做了好久好久,和 vj 上的样例就是不一样,后来看了我同学 A 的代码,也没有什么区别,后来我才知道 vj 上的样例是错的错的错的!!!(但是,我的这个题目上样例是对的)

Code

#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;

int dp[1002]; // 以 i 结尾的最长上升子序列的长度
int ans[1002];// 结果数组
int pre[1002];// 标记 i 对应的上一个数据

struct MICE
{
    int w;
    int v;
    int pos; // 老鼠的编号
} mice[1001];

bool cmp(MICE a,MICE b)
{
    if(a.w==b.w)
        return a.v>b.v;
    return a.w<b.w;
}


int main()
{
    int n,m;
    int flag=1;
    int maxx=0;;
    memset(dp,0,sizeof(dp));
    memset(ans,0,sizeof(ans));
    memset(pre,0,sizeof(pre));
    while(scanf("%d %d",&mice[flag].w,&mice[flag].v)!=EOF)
    {

        mice[flag].pos=flag;
        flag++;
    }

    sort(mice,mice+flag,cmp);

    int len=0;

    for(int i=1; i<flag; i++) // 套dp 求LIS 的模板
    {
        dp[i]=1; 
        pre[i]=i;
        for(int j=1; j<i; j++)
        {
            if(mice[i].w>mice[j].w&&mice[i].v<mice[j].v)
            {
                if(dp[i]<dp[j]+1){ 
                    dp[i]=dp[j]+1;
                    pre[i]=j; // 标记 i 的长度增加是从 j 增加得到的,记录下序号
                }
            }
        }
        if(len<dp[i])
        {
            len=dp[i]; // 求一个最长的 LIS 长度
            maxx=i;   // 记录 dp 增加的最后一个序号(不一定是老鼠的编号)
        }
    }
    cout<<len<<endl;

    int i=0;
    while(pre[maxx]!=maxx) //不等于 maxx 的话,就是 dp 增加,也就是LIS的子序列里边的序号
    {
        ans[i++]=mice[maxx].pos;// 记录到结果数组里边
        maxx=pre[maxx];
    }
    cout<<mice[maxx].pos<<endl; // 先输出LIS最后一个结尾的老鼠编号(此时已经排序好了)
    for(int j=i-1;j>=0;j--)
        cout<<ans[j]<<endl;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值