2021-01-22

二分查找

原本从1到n全部查找一遍时间复杂为o(n),但是用二分法查找可把时间复杂度降到o(logn)。
查找本身并不难,但是难点在于如何应用到题目中去,我觉得难点在于将题目翻译出来,然后找到满足题目条件的函数。

题目

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi

Output

  • Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#pragma warning(disable:4996)
using namespace std;
const int MAXN = 1e5 + 10;
const int inf = 0x3f3f3f3f;
long long  a[MAXN] = {0};
#define pi acos(-1.0)
int n, c;
bool check(int x)
{
	int i;int count = 1;long long  t = a[1];
	for (i = 2; i <=n; i++) {
		if (a[i] - t >= x) {
			t = a[i];
			count++;
			if (count >= c) {
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	while (~scanf("%d %d", &n, &c)) {
		for (int i = 1; i <= n; i++) {
			scanf("%lld", &a[i]);
		}
		sort(a + 1, a + n + 1);
		long long int l = 0, r = a[n] - a[1];
		long long ans;
		while (r > l) {
			long long mid = (l + r )/2;
			if (check(mid)) {
				ans = mid;
				l = mid+1 ;
			}
			else {
				r = mid;
			}
		}
		printf("%lld\n", ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值