PTA List Leaves(非链表题解)

本文提供了一道关于二叉树的题目,要求列出树中所有叶子节点,顺序为从上到下,从左到右。输入包含一棵最多10个节点的树,输出所有叶子节点的序号。解决方案利用队列实现类似层序遍历的方法,通过数组存储节点,以正确顺序打印叶子节点。
摘要由CSDN通过智能技术生成

题目如下:
7-4 List Leaves (25 分)
Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -

0 -
2 7

5 -
4 6
Sample Output:
4 1 5

思路:本题真正的难点不在于如何找到叶结点,而是如何按照题目的意思(in the order of top down, and left to right)从上到下,从左到右,将序号输出。
本题解使用队列方式存放所有结点的序号顺序,类似于层序遍历,由于该题并不复杂,因此运用了数组的方式存放,代码如下。

#include<stdio.h>
#define maxsize 15//N (≤10)
struct tree{
   
int left;
int right;
}t[maxsize];
typedef struct tree Tree;
int num;
int buildtree(Tree t[])//建立树,存放左右儿子的位置,并返回根结点位置
{
   
    int root,i,check[maxsize]={
   0};//利用check数组检查哪个位置的结点从未是别的结点的儿子,即该结点为根结点
    scanf("%d\n",&num);
    if(num)
    {
   
        for(i=0;i<num;i++)
    {
   
        scanf("%c %c\n",&t[i]
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值