POJ-1789 Truck History(Prim算法)

原题:

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24767 Accepted: 9654

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

题意:

给出n个字符串,可以看做n个结点,结点之间的距离就是两个字符串不同的字符数。求最小支撑树。
这个题我第一次用的Prim算法。简单说一下这个算法的做法:
首先任意选取一个结点加入生成树,dis数组储存其他结点到生成树的距离。
然后循环一下n-1次,添加n-1个结点:
从dis数组中找出最小值,即找到距离生成树最短的结点i,由此边构成最小生成树,然后标记i节点加入生成树。然后更新dis数组,即if(dis[i] > edge[i][j])。
循环完毕后n个结点都加入生成树,创建完毕。

代码:


#include <iostream>
#include <string>
#include <string.h>
using namespace std;
string type[2001];

int dd(string a, string b)
{
	int sum = 0;
	for(int i = 0;i < 7;i++)
		if(a[i]!=b[i])
			sum++;
	return sum;
}

bool vis[2001];
int dis[2001], edge[2001][2001];
int main()
{
    int n;
	while(cin>>n,n)
	{
		int sum = 0;
		memset(vis,false,sizeof(vis));
		for(int i = 0;i < n;i++)
			cin>>type[i];
		for(int i = 0;i < n;i++)
			for(int j = i+1;j < n;j++)
				edge[i][j] = edge[j][i] = dd(type[i],type[j]);
		vis[0] = true;
		for(int i = 1;i < n;i++)
		{
			dis[i] = edge[i][0];
		}
		for(int k = 1;k < n;k++)
		{
			int Min = 8, t;
			for(int i = 1;i < n;i++)
			{
				if(!vis[i] && dis[i]  < Min)
				{
					Min = dis[i];
					t = i;
				}
			}
			sum+= dis[t];
			vis[t] = true;
			for(int i = 0;i < n;i++)
			{
				if(!vis[i] && dis[i] > edge[t][i])
					dis[i] = edge[t][i];
			}
		}
		cout<<"The highest possible quality is 1/"<<sum<<'.'<<endl;
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值