POJ-1094 Sorting It All Out (拓扑排序)


Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32590 Accepted: 11324

Description

An  ascending (上升的) sorted  sequence (序列) of  distinct (明显的) values is one in which some form of a less-than operator is used to order the  elements (基础) from smallest to largest. For example, the sorted sequence A, B, C, D  implies (意味) that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified (指定) or not.

Input

Input (投入) consists of multiple problem  instances (实例). Each instance starts with a line containing two  positive (积极的)  integers (整数) n and m. the first value  indicated (表明) the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the  uppercase (以大写字母印刷)  alphabet (字母表). The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem  instance (实例)output (输出) consists of one line. This line should be one of the following three:

Sorted  sequence (序列) determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency (不一致) found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted,  ascending (上升的) sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:

告诉你共有n个结点,然后两两告诉你结点的关系。如果在告诉你第k个关系之后能确定n个结点的先后关系,则输出。
或者在第k个关系给出时发现与之前的关系矛盾,输出。
或者所有关系都给出了但无法确定n个结点的先后关系,输出相应结果。

思路:

利用向量 每输入一次进行一次拓扑排序即可

#include <iostream>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<cstdio>
using namespace std;

const int N = 30;
vector<int> ans, tot, vec[N];
int in[N], vis[N], tmp[N], cnt;

int topsort(int n)
{
	priority_queue<int, vector<int>, greater<int> > q;
	while(!q.empty()) q.pop();
	for(int i = 0;i < N;i++)
		tmp[i] = in[i];
	int rec = 0;
	
	for(int i = 0;i < 26;i++)
		if(!tmp[i] && vis[i])
		{
			q.push(i);
			++rec;
		}
		
	if(rec == 1)
		rec = 0;
	while(!q.empty())
	{
		int p = q.top();
		tot.push_back(p);
		q.pop();
		int v, len = vec[p].size();
		for(int i = 0;i < len;i++)
		{
			v = vec[p][i];
			tmp[v]--;
			if(!tmp[v])
				q.push(v), rec++;
		}
		if(rec == 1)
			rec = 0;
	}
	if(!rec && tot.size() == n)
		return 1;
	else if(tot.size() == cnt)
		return 0;
	else
		return -1;
}

int main()
{
    char a, b;
    int n, m, x, y, res, flag;
    while(cin>>n>>m,n&&m)
	{
		cnt = 0, flag = 0;
		memset(in,0,sizeof(in));
		memset(vis,0,sizeof(vis));
		for(int i = 0;i < N;i++)
			vec[i].clear();
		for(int i = 1;i <= m;i++)
		{
			scanf(" %c<%c",&a,&b);
			x = a-'A';
			y = b-'A';
			in[y]++;
			if(!vis[x]) ++cnt, vis[x] = 1;
			if(!vis[y]) ++cnt, vis[y] = 1;
			vec[x].push_back(y);
			if(!flag)
			{
				tot.clear();
				int k = topsort(n);
				if(k == 1)
				{
					ans = tot;
					flag = 1;
					res = i;
				}
				else if(k == -1)
				{
					flag = -1;
					res = i;
				}
			}
		}
		if(flag == 1)
		{
			printf("Sorted sequence determined after %d relations: ", res);  
            for(int i = 0; i < ans.size(); ++i) 
                printf("%c", 'A'+ans[i]);  
            puts("."); 
		}
		else if(!flag)
			printf("Sorted sequence cannot be determined.\n");
		else
			printf("Inconsistency found after %d relations.\n", res);
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值