POJ 3253 Fence Repair(贪心,优先队列)

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks
Lines 2… N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input

3
8
5
8

Sample Output

34

Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
百度翻译:
农夫约翰想修一小段牧场周围的篱笆。他测量了栅栏,发现他需要N(1≤N≤20000)块木板,每块木板都有一些整数长度的Li(1≤Li≤50000)单位。然后,他买了一块长木板,长度刚好能锯进N块木板(即,木板的长度是长度Li的总和)。FJ忽略了“切口”,即锯切时锯屑所损失的额外长度;你也应该忽略它。

福建悲哀地意识到,他没有一个锯与削减木材,所以他大摇大摆地到农民唐的农场与这长板,礼貌地问他是否可以借用一把锯。

农民唐,一个秘密资本家,不借给FJ一把锯子,而是提出向农民约翰收取木板上每一个N-1切口的费用。砍一块木头的费用正好等于它的长度。切割一块长21的木板要花21美分。

农夫唐让农夫约翰决定切割木板的顺序和地点。帮助农场主约翰确定他能花多少钱来制作木板。福建知道,他可以削减董事会在不同的顺序,这将导致不同的费用,因为产生的中间木板是不同的长度。

输入
第1行:一个整数N,木板的数量
第2行。。N+1:每行包含一个整数,用于描述所需木板的长度
输出
第1行:一个整数:他必须花费最少的钱来进行N-1次削减
样本输入


5个

样本输出
34个
暗示
他想把一块21长的木板切成8、5和8长的几块。
原来的棋盘是8+5+8=21。第一次切割要花21英镑,应该用来把木板切成13和8块。第二次削减将花费13,并应用于削减13成8和5。这将花费21+13=34。如果把21分为16分和5分,第二次削减将花费16分,总共37分(超过34分)。

解析:
由于是要把一个大木板切成若干小木板,直接切大木板不知道应该切成多大的两块最省钱,这样的话就要反着来,找到最小的两个,合并后用合并后的数取代最小的那个数,用最后那个数取代第二小的那个数,之后再进行重复操作,直到只有一块木板;

代码:

#include"stdio.h"
#include"algorithm"
using namespace std;
int a[20010];
int main()
{
	int m,min1,min2,i,t;
	long long s=0;
	scanf("%d",&m);
	for(i=0;i<m;i++)
	scanf("%d",&a[i]);
	while(m>1)
	{
		min1=0;
		min2=1;
		if(a[min1]>a[min2])
		swap(min1,min2);
		for(i=2;i<m;i++)
		{
			if(a[i]<a[min1])
			{
				min2=min1;
				min1=i;
			}
			else if(a[i]<a[min2])
			min2=i;
		}
		t=a[min1]+a[min2];
		s+=t;
		if(min1==m-1)
		swap(min1,min2);
		a[min1]=t;
		a[min2]=a[m-1];
		m--;
	}
	printf("%lld\n",s);
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值