Palindrome POJ 1159 动态规划

2 篇文章 0 订阅

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
#include "stdio.h"
const int N=5010;
char s[N];
int c[N][N]={0};
int n;
int min(int a,int b)
{
	if(a<b)
		return a;
	else
		return b;
}
int Dp(int i,int j)
{
	if(i==j)
		return 0;
	if(i>j)
		return 0;
	if(c[i][j]!=0)
		return c[i][j];
	if(s[i]==s[j])
		c[i][j]=Dp(i+1,j-1);
	else
		c[i][j]=min(Dp(i+1,j),Dp(i,j-1))+1;
	return c[i][j];
}
int main()
{
	scanf("%d",&n);
	scanf("\n%s",s+1);
	printf("%d\n",Dp(1,n));
return 0;
}

动态规划这是个很好的例子。做为我一个学习笔记。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值