紫书第五章习题 5-1 UVa 1593 Alignment of Code

出处:https://blog.csdn.net/u014004096/article/details/41490339

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input 

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output 

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.


Note for the Sample:

The `$ \sqcup$' character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input 

  start:  integer;    // begins here
stop: integer; //  ends here  
 s:  string;   
c:   char; // temp

Sample Output 

start: integer; // begins here 
stop:  integer; // ends   here 
s:     string;
c:     char;    // temp

题意:

输入若干行代码,要求各列单词的左边界对齐且尽量靠左。

单词之间至少要空一格。每个单词不超过80个字符,

每行不超过180个字符,一共最多1000行。


注意输出时每行的最后一列后面没有空格符。

 

代码如下:代码中有详细的注释!


<pre name="code" class="cpp">#include<iostream>  
#include<sstream>  
#include<string>  
#include<vector>  
using namespace std;  
vector<string> txt[1314];  
string code,te;  
int max_len[250];//将每一列中最长的单词的长度保存下来,以便保证格式!  
void print(string s,int len)  
{//格式化输出!  
    for(int i=0; i<s.size(); i++)  
        cout<<s[i];  
    for(int i=0; i<=len-s.size(); i++)  
        cout<<' ';  
    //cout<<'*';  
}  
int main()  
{  
    int col=0,row=0;//代码行数,col表示每一行的“单词”个数!  
    while(getline(cin,code))  
    {  
        stringstream tran(code);//创建一个“字符串流”——tran,接下来只需要像读取cin那样读取tran即可!  
        while(tran>>te)  
        {  
            max_len[col]=max(max_len[col],(int)te.size());//比较长度取大值。  
            col++;  
            txt[row].push_back(te);//将每一个单词存进容器里面!  
        }  
        row++,col=0;  
    }  
    for(int i=0; i<row; i++)  
    {  
        int j=0;  
        for(; j<txt[i].size()-1; j++)  
            print(txt[i][j],max_len[j]);  
        cout<<txt[i][j]<<endl;//每行的最后一列是不用输出空格的!  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sure! Here's an example of a 4-lane MIPI data alignment module written in Verilog: ```verilog module mipi_data_alignment ( input [31:0] data_in, input clk, input rst, output reg [31:0] data_out ); reg [31:0] shift_reg [0:3]; always @(posedge clk or posedge rst) begin if (rst) begin for (int i = 0; i < 4; i = i + 1) begin shift_reg[i] <= 32'b0; end end else begin for (int i = 0; i < 4; i = i + 1) begin shift_reg[i] <= {shift_reg[i][30:0], data_in[i*8 +: 8]}; end end end always @(posedge clk) begin if (rst) begin data_out <= 32'b0; end else begin for (int i = 0; i < 4; i = i + 1) begin data_out[i*8 +: 8] <= shift_reg[i][31:24]; end end end endmodule ``` In this module, `data_in` is a 32-bit input representing the MIPI data for the four lanes, `clk` is the clock signal, `rst` is the reset signal, and `data_out` is the aligned output data for the four lanes. The array `shift_reg[0:3]` consists of four 32-bit shift registers, each corresponding to one lane. On each rising edge of the clock (`clk`), the data for each lane is shifted left by eight bits, and the new input data for each lane is concatenated to the rightmost eight bits of the corresponding shift register. This aligns the incoming MIPI data stream for each lane. The aligned output data for each lane is updated on each rising edge of the clock based on the current values of the shift registers. Remember to customize this code according to your specific requirements and the MIPI protocol specifications you are working with.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值