4-14 还原二叉树&&4-15 根据后序和中序遍历输出先序遍历

4-14 还原二叉树

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入格式:

输入首先给出正整数N(≤50),为树中结点总数。下面两行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区别大小写)的字符串。

输出格式:

输出为一个整数,即该二叉树的高度。

输入样例:

9
ABDFGHIEC
FDHGIBEAC

输出样例:

5

代码:

#include <stdio.h>
#include <stdlib.h>

typedef struct Tree {
    char data;
    Tree* lchild;
    Tree* rchild;
};

Tree* get(char preod[], char inod[], int len) {
    int i;
    if (len <= 0) {
        return NULL;
    }
    Tree* t = (Tree*)malloc(sizeof(Tree));
    t->data = preod[0];
    for (i = 0; inod[i] != preod[0]; i++);
    t->lchild = get(preod + 1, inod, i);
    t->rchild = get(preod + i + 1, inod + i + 1, len - i - 1);
    return t;
}

int getlen(Tree* t){
    if (t == NULL) {
        return 0;
    }
    int left = getlen(t->lchild);
    int right = getlen(t->rchild);
    return (left >= right ? left : right)+1;
}

int main()
{
    int n;
    scanf("%d", &n);
    char s1[200], s2[200];
    scanf("%s", &s1);
    scanf("%s", &s2);

    printf("%d", getlen(get(s1, s2, n)));

    return 0;
}

生成的树:

 


4-15 根据后序和中序遍历输出先序遍历

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:

第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:

在一行中输出Preorder: 以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

Preorder: 4 1 3 2 6 5 7

代码:

#include<iostream>
using namespace std;

typedef int ElementType;
typedef struct TNode* Position;
typedef Position BinTree;
struct TNode {
    ElementType Data;
    BinTree Left;
    BinTree Right;
};
BinTree get(int s1[], int s2[], int n) {
    int i;
    if (n <= 0) {
        return NULL;
    }
    BinTree newtree = (BinTree)malloc(sizeof(struct TNode));
    newtree->Data = s1[n - 1];
    newtree->Left = NULL;
    newtree->Right = NULL;

    for (i = 0; s2[i] != s1[n-1]; i++);
    newtree->Left = get(s1, s2, i);
    newtree->Right = get(s1 + i, s2 + i + 1, n - i - 1);
    return newtree;
}

void show(BinTree tree) {
    if (!tree) {
        return;
    }
    printf(" %d", tree->Data);
    show(tree->Left);
    show(tree->Right);
}



int main()
{
    int n;
    scanf("%d", &n);
    int s1[40], s2[40];
    for (int i = 0; i < n; i++) {
        scanf("%d", &s1[i]);
    }
    for (int i = 0; i < n; i++) {
        scanf("%d", &s2[i]);
    }
    
    printf("Preorder:");
    show(get(s1, s2, n));

    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值