error: Microsoft Visual C++ 14.0 is required. Get it with ;Microsoft Visual C++ Build Tools;

版权声明:原创文章,转载请注明出处,来自https://blog.csdn.net/Jacabe https://blog.csdn.net/Jacabe/article/details/80039564

版本声明:原创文章,转载请注明出处

错误:

 No module named 'numpy.distutils._msvccompiler' in numpy.distutils; trying from distutils
    error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools

    ----------------------------------------

Command ""c:\program files (x86)\python\python.exe" -u -c "import setuptools, tokenize;__file__='C:\\Users\\86330\\AppData\\Local\\Temp\\pip-install-dcfwcckc\\numpy\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\86330\AppData\Local\Temp\pip-record-gf88smf7\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in C:\Users\86330\AppData\Local\Temp\pip-install-dcfwcckc\numpy\


出现这种错误,是因为 numpy没有安装成功,或者是以为numpy版本不正确

可以到下面地址去下载对应的版本:

https://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy


如我的是 python 3.6.5 我选的是 numpy-1.14.2+mkl-cp36-cp36m-win_amd64.whl

选的是1.14.2版本

其中 cp36 - this package is for CPython. IronPython, Jython, or PyPy will probably be unhappy. 

  • CPython version 3.6.
  • 就是指的是 python的版本了 3.6的版本

运行命令:

pip install numpy-1.14.2+mkl-cp36-cp36m-win_amd64.whl

就安装好 numpy 1.14.2的版本了


下载相应的文件即可 
要注意的是要下载跟自己python相对应的版本

否则会出现以下报错


阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页