D - Paths on a Grid POJ - 1942

链接:http://poj.org/problem?id=1942
Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he’s explaining that (a+b) 2=a 2+2ab+b 2). So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:

Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce? 

Input
The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.
Output
For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input

5 4
1 1
0 0

Sample Output

126
2

显然结果是C(m + n,n) = C(m + n,m) 有因为m,n较大,先考虑清楚,但结果也是unsined int,因为m+n一旦增大,其增长速度非常快,并且对于每一个C(n,k),k = n/2 时最大,考虑一下即能够知道实际上该题的时间复杂度并没有想象中的那么高,这是因为我们只需求C(m + n,n) = C(m + n,m),两者中的任意一个,并且始终有一个是相对小的,因为题目保证了结果在unsined int以内,这一点读者可自行验证。另外用到一个公式C(n,k) = C(n - 1,k - 1) * n / k,保证n > m后,于是我们只需从C(n + 1,1)开始递推即可。

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
long long cal(long long n,long long m){
        long long i = n + 1,j = 1;
        long long ans = 1;
        while(j <= m){
                ans = ans * i / j;
                j++;
                i++;
        }
        return ans;
}
int main(){
        long long n,m;
        while(~scanf("%lld%lld",&n,&m)){
                if(n == 0 && m == 0){
                        break;
                }
        if(m > n){
            swap(n,m);
        }
                printf("%lld\n",cal(n,m));
        }
        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值